summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2009-08-24 07:25:30 +0000
committerMichael Raskin <7c6f434c@mail.ru>2009-08-24 07:25:30 +0000
commit6770d7aa4d725fd14d103b30416f3ba884f0cb69 (patch)
tree271d4dfb5f82c494526b293794af957cca4e649b /pkgs/development
parent2f8c8d39e8e7a72cb6463f180c85e87b7fce7110 (diff)
downloadnixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.tar
nixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.tar.gz
nixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.tar.bz2
nixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.tar.lz
nixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.tar.xz
nixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.tar.zst
nixlib-6770d7aa4d725fd14d103b30416f3ba884f0cb69.zip
Downgrade WebKit - probably enough to go with old libsoup. Libsoup mostly updated, but it seems to require fresher unstable gtk...
svn path=/nixpkgs/trunk/; revision=16826
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/gtk-libs/2.16/default.nix1
-rw-r--r--pkgs/development/libraries/gtk-libs/2.16/glib/2.21.4.nix27
-rw-r--r--pkgs/development/libraries/webkit/default.nix5
-rw-r--r--pkgs/development/libraries/webkit/src-for-default.nix6
4 files changed, 35 insertions, 4 deletions
diff --git a/pkgs/development/libraries/gtk-libs/2.16/default.nix b/pkgs/development/libraries/gtk-libs/2.16/default.nix
index 89abc0e62086..71444890e949 100644
--- a/pkgs/development/libraries/gtk-libs/2.16/default.nix
+++ b/pkgs/development/libraries/gtk-libs/2.16/default.nix
@@ -3,6 +3,7 @@ args: with args;
 rec {
 
   glib = (import ./glib) args;
+  glib_2_21 = (import ./glib/2.21.4.nix) args;
 
   atk = (import ./atk) (args // { inherit glib; });
 
diff --git a/pkgs/development/libraries/gtk-libs/2.16/glib/2.21.4.nix b/pkgs/development/libraries/gtk-libs/2.16/glib/2.21.4.nix
new file mode 100644
index 000000000000..86934bc94d15
--- /dev/null
+++ b/pkgs/development/libraries/gtk-libs/2.16/glib/2.21.4.nix
@@ -0,0 +1,27 @@
+args: with args;
+
+stdenv.mkDerivation rec {
+  name = "glib-2.21.4";
+  
+  src = fetchurl {
+    url = "mirror://gnome/sources/glib/2.21/${name}.tar.bz2";
+    sha256 = "b772e4bdf1b28dd23cdb4c4d7f1d219ddb748226d0207e57c75992bf0100182d";
+  };
+  
+  buildInputs = [pkgconfig gettext perl];
+
+  meta = {
+    description = "GLib, a C library of programming buildings blocks";
+
+    longDescription = ''
+      GLib provides the core application building blocks for libraries
+      and applications written in C.  It provides the core object
+      system used in GNOME, the main loop implementation, and a large
+      set of utility functions for strings and common data structures.
+    '';
+
+    homepage = http://www.gtk.org/;
+
+    license = "LGPLv2+";
+  };
+}
diff --git a/pkgs/development/libraries/webkit/default.nix b/pkgs/development/libraries/webkit/default.nix
index 9fd1b2415518..b5a305ad4a04 100644
--- a/pkgs/development/libraries/webkit/default.nix
+++ b/pkgs/development/libraries/webkit/default.nix
@@ -27,7 +27,10 @@ rec {
     "--enable-web-sockets"
     # Fails the build..
     # "--enable-shared-workers"
-    "--enable-wml"
+    # Related to Slashdot.org crash
+    # fixed upstream, but fresh release requires 
+    # too many updates
+    #"--enable-wml"
     ];
 
   /* doConfigure should be specified separately */
diff --git a/pkgs/development/libraries/webkit/src-for-default.nix b/pkgs/development/libraries/webkit/src-for-default.nix
index 3e1c2fb472ff..099f9c0a9653 100644
--- a/pkgs/development/libraries/webkit/src-for-default.nix
+++ b/pkgs/development/libraries/webkit/src-for-default.nix
@@ -1,6 +1,6 @@
 rec {
-  advertisedUrl="http://builds.nightly.webkit.org/files/trunk/src/WebKit-r47686.tar.bz2";
-  version = "r47686";
+  advertisedUrl="http://builds.nightly.webkit.org/files/trunk/src/WebKit-r47291.tar.bz2";
+  version = "r47291";
   url="http://builds.nightly.webkit.org/files/trunk/src/WebKit-${version}.tar.bz2";
-  hash = "1h1frvvp8hfv3q2drjnrpgadgin55p7nv8747kxxhdkj4gv9dzqg";
+  hash = "14rggsgpsaxfph1967hbwlz814d8zyzl6xwzl7a25f6zf1nwcjdk";
 }