summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2018-09-12 01:10:11 +0100
committerJörg Thalheim <joerg@thalheim.io>2018-09-12 09:03:08 +0100
commit63668d33b208790ce91e0ec53e263dd18bb5aba4 (patch)
treed41dfcbd36e06652963e261317bf81dc84372e9c /pkgs/development
parente4393102e673f990521dc109dfd4f27ceca9e437 (diff)
downloadnixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.tar
nixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.tar.gz
nixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.tar.bz2
nixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.tar.lz
nixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.tar.xz
nixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.tar.zst
nixlib-63668d33b208790ce91e0ec53e263dd18bb5aba4.zip
python-language-server: 0.19.0 -> 0.21.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/python-language-server/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/development/python-modules/python-language-server/default.nix b/pkgs/development/python-modules/python-language-server/default.nix
index 800c9eba2abb..56c00fa11a9f 100644
--- a/pkgs/development/python-modules/python-language-server/default.nix
+++ b/pkgs/development/python-modules/python-language-server/default.nix
@@ -1,5 +1,5 @@
 { stdenv, buildPythonPackage, fetchFromGitHub, pythonOlder, isPy27
-, configparser, futures, future, jedi, pluggy
+, configparser, futures, future, jedi, pluggy, python-jsonrpc-server
 , pytest, mock, pytestcov, coverage
 , # Allow building a limited set of providers, e.g. ["pycodestyle"].
   providers ? ["*"]
@@ -20,13 +20,13 @@ in
 
 buildPythonPackage rec {
   pname = "python-language-server";
-  version = "0.19.0";
+  version = "0.21.2";
 
   src = fetchFromGitHub {
     owner = "palantir";
     repo = "python-language-server";
     rev = version;
-    sha256 = "0glnhnjmsnnh1vs73n9dglknfkhcgp03nkjbpz0phh1jlqrkrwm6";
+    sha256 = "11fvrpv1kymj2fzh8fhys4qk1xc64j1rbdrz252awyab7b3509i7";
   };
 
   # The tests require all the providers, disable otherwise.
@@ -43,7 +43,7 @@ buildPythonPackage rec {
     HOME=$TEMPDIR pytest
   '';
 
-  propagatedBuildInputs = [ jedi pluggy future ]
+  propagatedBuildInputs = [ jedi pluggy future python-jsonrpc-server ]
     ++ stdenv.lib.optional (withProvider "autopep8") autopep8
     ++ stdenv.lib.optional (withProvider "mccabe") mccabe
     ++ stdenv.lib.optional (withProvider "pycodestyle") pycodestyle