summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-10-23 14:54:17 +0200
committerRobin Gloster <mail@glob.in>2017-10-24 15:31:51 +0200
commit62ca1c2dab3ebec9dad25492f7274ea262fdbce0 (patch)
tree52255c34e2707f1786b5ebe4a53b47f9c4d3def9 /pkgs/development
parentb10a98cee748aa6474451969144c073ab77ea2a7 (diff)
downloadnixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.tar
nixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.tar.gz
nixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.tar.bz2
nixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.tar.lz
nixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.tar.xz
nixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.tar.zst
nixlib-62ca1c2dab3ebec9dad25492f7274ea262fdbce0.zip
mistune: 0.7.1 -> 0.7.4, own file
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/mistune/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/mistune/default.nix b/pkgs/development/python-modules/mistune/default.nix
new file mode 100644
index 000000000000..14aef5b00d12
--- /dev/null
+++ b/pkgs/development/python-modules/mistune/default.nix
@@ -0,0 +1,24 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, nose
+}:
+
+buildPythonPackage rec {
+  pname = "mistune";
+  version = "0.7.4";
+  name = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0byj9jg9ly7karf5sb1aqcw7avaim9sxl8ws7yw7p1fibjgsy5w5";
+  };
+
+  buildInputs = [ nose ];
+
+  meta = with lib; {
+    description = "The fastest markdown parser in pure Python";
+    homepage = https://github.com/lepture/mistune;
+    license = licenses.bsd3;
+  };
+}