summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2015-10-04 10:43:34 +0200
committerVincent Laporte <Vincent.Laporte@gmail.com>2015-10-20 21:53:12 +0200
commit62a7ba20c1d1804b8d4b18c371112470ac6b0f73 (patch)
tree007ddf1e2ba147cdac0741bb11f219d005141316 /pkgs/development
parentc0a963e3cc6bd9c049f6db198a6acf92ee795e4e (diff)
downloadnixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.tar
nixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.tar.gz
nixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.tar.bz2
nixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.tar.lz
nixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.tar.xz
nixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.tar.zst
nixlib-62a7ba20c1d1804b8d4b18c371112470ac6b0f73.zip
ocaml-ppx_tools: init at 0.99.2
Tools for authors of ppx rewriters

Homepage: https://github.com/alainfrisch/ppx_tools
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/ppx_tools/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/ppx_tools/default.nix b/pkgs/development/ocaml-modules/ppx_tools/default.nix
new file mode 100644
index 000000000000..4e99dcd1af45
--- /dev/null
+++ b/pkgs/development/ocaml-modules/ppx_tools/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchzip, ocaml, findlib }:
+
+stdenv.mkDerivation {
+  name = "ocaml-ppx_tools-0.99.2";
+  src = fetchzip {
+    url = https://github.com/alainfrisch/ppx_tools/archive/ppx_tools_0.99.2.tar.gz;
+    sha256 = "1m09r2sjcb37i4dyhpbk9n2wxkcvpib6bvairsird91fm9w0vqw7";
+  };
+
+  buildInputs = [ ocaml findlib ];
+
+  createFindlibDestdir = true;
+
+  meta = with stdenv.lib; {
+    description = "Tools for authors of ppx rewriters";
+    homepage = http://www.lexifi.com/ppx_tools;
+    license = licenses.mit;
+    platforms = ocaml.meta.platforms;
+    maintainers = with maintainers; [ vbgl ];
+  };
+}