summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-10 13:10:47 -0400
committerChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-10 13:10:47 -0400
commit61c83b108d4141d57c242aa769caca9a55411ed0 (patch)
treeff9bec82e073dd2e10854cdf07c71f0ba4696a97 /pkgs/development
parent29d0eec15faa315b45bbae08f43ac40e7cb2b4aa (diff)
downloadnixlib-61c83b108d4141d57c242aa769caca9a55411ed0.tar
nixlib-61c83b108d4141d57c242aa769caca9a55411ed0.tar.gz
nixlib-61c83b108d4141d57c242aa769caca9a55411ed0.tar.bz2
nixlib-61c83b108d4141d57c242aa769caca9a55411ed0.tar.lz
nixlib-61c83b108d4141d57c242aa769caca9a55411ed0.tar.xz
nixlib-61c83b108d4141d57c242aa769caca9a55411ed0.tar.zst
nixlib-61c83b108d4141d57c242aa769caca9a55411ed0.zip
pythonPackages.escapism: 0.0.1 -> 1.0.0 move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/escapism/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/escapism/default.nix b/pkgs/development/python-modules/escapism/default.nix
new file mode 100644
index 000000000000..b2ac36582357
--- /dev/null
+++ b/pkgs/development/python-modules/escapism/default.nix
@@ -0,0 +1,24 @@
+{ pkgs
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+  pname = "escapism";
+  version = "1.0.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "5f1cc1fa04a95f5b85b3da194750f8a71846d493ea332f62e8798949f10c9b86";
+  };
+
+  # No tests distributed
+  doCheck = false;
+
+  meta = with pkgs.lib; {
+    description = "Simple, generic API for escaping strings";
+    homepage = "https://github.com/minrk/escapism";
+    license = licenses.mit;
+    maintainers = with maintainers; [ bzizou ];
+  };
+}