summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-13 17:45:18 -0400
committerMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 02:34:32 -0400
commit5bdce80515554f05d6d65853ad01d144a5d9b718 (patch)
tree193de5c03c0820b93cb6917f7a40a65075120ff9 /pkgs/development
parent95d9e2b86a0a3fb078f844592c626501d52e09d8 (diff)
downloadnixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.tar
nixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.tar.gz
nixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.tar.bz2
nixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.tar.lz
nixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.tar.xz
nixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.tar.zst
nixlib-5bdce80515554f05d6d65853ad01d144a5d9b718.zip
ppx_optcomp: init at 113.33.03
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/janestreet/ppx-optcomp.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/janestreet/ppx-optcomp.nix b/pkgs/development/ocaml-modules/janestreet/ppx-optcomp.nix
new file mode 100644
index 000000000000..5dcfc97bfa37
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/ppx-optcomp.nix
@@ -0,0 +1,15 @@
+{stdenv, buildOcamlJane,
+ ppx_core, ppx_tools}:
+
+buildOcamlJane rec {
+  name = "ppx_optcomp";
+  hash = "09m2x2a5ics4bz1j29n5slhh1rlyhcwdfmf44v1jfxcby3f0riwd";
+  propagatedBuildInputs =
+    [ ppx_core ppx_tools ];
+
+  meta = with stdenv.lib; {
+    description = "ppx_optcomp stands for Optional Compilation. It is a tool used to handle optional compilations of pieces of code depending of the word size, the version of the compiler, etc.";
+    maintainers = [ maintainers.maurer ];
+    license = licenses.asl20;
+  };
+}