summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2017-09-03 15:42:05 +0300
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-05 09:04:56 +0200
commit596d87c13edfb6ded1ac7507e31aab874d53c6dc (patch)
treebaf804b83f94e9d391e96cf19d91122970928147 /pkgs/development
parent196fbee1bbf21cb01096adc9d34e1f42e1095bfd (diff)
downloadnixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.tar
nixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.tar.gz
nixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.tar.bz2
nixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.tar.lz
nixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.tar.xz
nixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.tar.zst
nixlib-596d87c13edfb6ded1ac7507e31aab874d53c6dc.zip
pythonPackages.pytest-flake8: fix strict mode
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pytest-flake8/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/pkgs/development/python-modules/pytest-flake8/default.nix b/pkgs/development/python-modules/pytest-flake8/default.nix
index 93883283627e..b39737ea7019 100644
--- a/pkgs/development/python-modules/pytest-flake8/default.nix
+++ b/pkgs/development/python-modules/pytest-flake8/default.nix
@@ -1,4 +1,4 @@
-{lib, buildPythonPackage, fetchPypi, pytest, flake8}:
+{lib, buildPythonPackage, fetchPypi, fetchpatch, pytest, flake8}:
 
 buildPythonPackage rec {
   name = "${pname}-${version}";
@@ -16,6 +16,16 @@ buildPythonPackage rec {
     sha256 = "1za5i09gz127yraigmcl443w6149714l279rmlfxg1bl2kdsc45a";
   };
 
+  patches = [
+    # Fix pytest strict mode (pull request #24)
+    # https://github.com/tholo/pytest-flake8/pull/24
+    (fetchpatch {
+      name = "fix-compatibility-with-pytest-strict-mode.patch";
+      url = "https://github.com/tholo/pytest-flake8/commit/434e1b07b4b77bfe1ddb9b2b54470c6c3815bb1a.patch";
+      sha256 = "0idwgkwwysx2cibnykd81yxrgqzkpf42j99jmpnanqzi99qnc3wx";
+    })
+  ];
+
   checkPhase = ''
     pytest --ignore=nix_run_setup.py .
   '';