summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2016-09-06 10:07:14 +0200
committerMichael Raskin <7c6f434c@mail.ru>2016-09-06 18:19:17 +0200
commit592e265caae8ec156b6b3a6a3b96f082a5368e18 (patch)
tree7eeb94a116de3005bed9ff5fceb9c9fb34877162 /pkgs/development
parent8f284c0a941a402039266d1fb07edde55635dceb (diff)
downloadnixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.tar
nixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.tar.gz
nixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.tar.bz2
nixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.tar.lz
nixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.tar.xz
nixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.tar.zst
nixlib-592e265caae8ec156b6b3a6a3b96f082a5368e18.zip
antlr3_4: init at 3.4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/parsing/antlr/3.4.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/development/tools/parsing/antlr/3.4.nix b/pkgs/development/tools/parsing/antlr/3.4.nix
new file mode 100644
index 000000000000..a92e8aa72518
--- /dev/null
+++ b/pkgs/development/tools/parsing/antlr/3.4.nix
@@ -0,0 +1,38 @@
+{stdenv, fetchurl, jre}:
+
+stdenv.mkDerivation rec {
+  name = "antlr-${version}";
+  version = "3.4";
+  src = fetchurl {
+    url ="http://www.antlr3.org/download/antlr-${version}-complete.jar";
+    sha256 = "1xqbam8vf04q5fasb0m2n1pn5dbp2yw763sj492ncq04c5mqcglx";
+  };
+
+  unpackPhase = "true";
+ 
+  installPhase = ''
+    mkdir -p "$out"/{lib/antlr,bin}
+    cp "$src" "$out/lib/antlr/antlr-${version}-complete.jar"
+
+    echo "#! ${stdenv.shell}" >> "$out/bin/antlr"
+    echo "'${jre}/bin/java' -cp '$out/lib/antlr/antlr-${version}-complete.jar' -Xms200M -Xmx400M org.antlr.Tool \"\$@\"" >> "$out/bin/antlr"
+
+    chmod a+x "$out/bin/antlr"
+    ln -s "$out/bin/antlr"{,3}
+  '';
+
+  inherit jre;
+
+  meta = with stdenv.lib; {
+    description = "Powerful parser generator";
+    longDescription = ''
+      ANTLR (ANother Tool for Language Recognition) is a powerful parser
+      generator for reading, processing, executing, or translating structured
+      text or binary files. It's widely used to build languages, tools, and
+      frameworks. From a grammar, ANTLR generates a parser that can build and
+      walk parse trees.
+    '';
+    homepage = http://www.antlr.org/;
+    platforms = platforms.linux;
+  };
+}