summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-04 22:47:01 +0100
committerRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-04 22:47:01 +0100
commit58e467c850435fd787dec70a6752d852fc6c67fa (patch)
treed06594995f4682b2b49276efd5f104d00b160c1c /pkgs/development
parent0cef410c08d00f2d6f774651947d8137a97935ba (diff)
downloadnixlib-58e467c850435fd787dec70a6752d852fc6c67fa.tar
nixlib-58e467c850435fd787dec70a6752d852fc6c67fa.tar.gz
nixlib-58e467c850435fd787dec70a6752d852fc6c67fa.tar.bz2
nixlib-58e467c850435fd787dec70a6752d852fc6c67fa.tar.lz
nixlib-58e467c850435fd787dec70a6752d852fc6c67fa.tar.xz
nixlib-58e467c850435fd787dec70a6752d852fc6c67fa.tar.zst
nixlib-58e467c850435fd787dec70a6752d852fc6c67fa.zip
python3Packages.aioimaplib: init at 0.7.13
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/aioimaplib/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/aioimaplib/default.nix b/pkgs/development/python-modules/aioimaplib/default.nix
new file mode 100644
index 000000000000..d335cbc556cb
--- /dev/null
+++ b/pkgs/development/python-modules/aioimaplib/default.nix
@@ -0,0 +1,26 @@
+{ lib, buildPythonPackage, fetchFromGitHub, pythonOlder
+, nose, asynctest, mock, pytz, tzlocal, imaplib2, docutils }:
+
+buildPythonPackage rec {
+  pname = "aioimaplib";
+  version = "0.7.13";
+
+  # PyPI tarball doesn't ship tests
+  src = fetchFromGitHub {
+    owner = "bamthomas";
+    repo = pname;
+    rev = version;
+    sha256 = "19yhk4ixfw46d0bvx6a40r23nvia5a83dzn5rzwaq1wdjr186bbn";
+  };
+
+  disbaled = pythonOlder "3.4";
+
+  checkInputs = [ nose asynctest mock pytz tzlocal imaplib2 docutils ];
+
+  meta = with lib; {
+    description = "Python asyncio IMAP4rev1 client library";
+    homepage = https://github.com/bamthomas/aioimaplib;
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}