summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-08-21 12:05:10 +0200
committerGitHub <noreply@github.com>2018-08-21 12:05:10 +0200
commit54ff14b6f35e1c396dc51f7bab13e00a64db22dd (patch)
tree28f060e7ab353a6da12517fd64d02f65b3b9a083 /pkgs/development
parent3ec19b174f04bd8eab390212bd2015e8e2339381 (diff)
parent27c74747f7e24c3be1154495cb75b6790ebe19f2 (diff)
downloadnixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.tar
nixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.tar.gz
nixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.tar.bz2
nixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.tar.lz
nixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.tar.xz
nixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.tar.zst
nixlib-54ff14b6f35e1c396dc51f7bab13e00a64db22dd.zip
Merge pull request #45399 from markuskowa/license-8
Add licenses
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/gdata-sharp/default.nix2
-rw-r--r--pkgs/development/libraries/gdcm/default.nix5
-rw-r--r--pkgs/development/libraries/gdk-pixbuf/default.nix1
-rw-r--r--pkgs/development/libraries/gettext/default.nix7
-rw-r--r--pkgs/development/libraries/giflib/4.1.nix6
-rw-r--r--pkgs/development/libraries/gio-sharp/default.nix2
-rw-r--r--pkgs/development/libraries/gnet/default.nix1
-rw-r--r--pkgs/development/libraries/pth/default.nix7
-rw-r--r--pkgs/development/tools/glock/default.nix1
9 files changed, 22 insertions, 10 deletions
diff --git a/pkgs/development/libraries/gdata-sharp/default.nix b/pkgs/development/libraries/gdata-sharp/default.nix
index 40e9b0ed90d5..a9b79dac7b88 100644
--- a/pkgs/development/libraries/gdata-sharp/default.nix
+++ b/pkgs/development/libraries/gdata-sharp/default.nix
@@ -34,6 +34,8 @@ in stdenv.mkDerivation rec {
       The Google Data APIs provide a simple protocol for reading and writing
       data on the web.
     '';
+
+    license = licenses.asl20;
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/development/libraries/gdcm/default.nix b/pkgs/development/libraries/gdcm/default.nix
index a4eab462046c..cba31f45d557 100644
--- a/pkgs/development/libraries/gdcm/default.nix
+++ b/pkgs/development/libraries/gdcm/default.nix
@@ -26,14 +26,15 @@ stdenv.mkDerivation rec {
   buildInputs = [ cmake vtk ];
   propagatedBuildInputs = [ ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "The grassroots cross-platform DICOM implementation";
     longDescription = ''
       Grassroots DICOM (GDCM) is an implementation of the DICOM standard designed to be open source so that researchers may access clinical data directly.
       GDCM includes a file format definition and a network communications protocol, both of which should be extended to provide a full set of tools for a researcher or small medical imaging vendor to interface with an existing medical database.
     '';
     homepage = http://gdcm.sourceforge.net/;
-    platforms = stdenv.lib.platforms.all;
+    license = with licenses; [ bsd3 asl20 ];
+    platforms = platforms.all;
   };
 }
 
diff --git a/pkgs/development/libraries/gdk-pixbuf/default.nix b/pkgs/development/libraries/gdk-pixbuf/default.nix
index 94536f8f5b69..3fb50e98c1c8 100644
--- a/pkgs/development/libraries/gdk-pixbuf/default.nix
+++ b/pkgs/development/libraries/gdk-pixbuf/default.nix
@@ -116,6 +116,7 @@ stdenv.mkDerivation rec {
     description = "A library for image loading and manipulation";
     homepage = http://library.gnome.org/devel/gdk-pixbuf/;
     maintainers = [ maintainers.eelco ];
+    license = licenses.lgpl21;
     platforms = platforms.unix;
   };
 }
diff --git a/pkgs/development/libraries/gettext/default.nix b/pkgs/development/libraries/gettext/default.nix
index 07db27dcc791..469dcbf75bbe 100644
--- a/pkgs/development/libraries/gettext/default.nix
+++ b/pkgs/development/libraries/gettext/default.nix
@@ -52,7 +52,7 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  meta = {
+  meta = with lib; {
     description = "Well integrated set of translation tools and documentation";
 
     longDescription = ''
@@ -76,8 +76,9 @@ stdenv.mkDerivation rec {
 
     homepage = http://www.gnu.org/software/gettext/;
 
-    maintainers = with lib.maintainers; [ zimbatm vrthra ];
-    platforms = lib.platforms.all;
+    maintainers = with maintainers; [ zimbatm vrthra ];
+    license = licenses.gpl2Plus;
+    platforms = platforms.all;
   };
 }
 
diff --git a/pkgs/development/libraries/giflib/4.1.nix b/pkgs/development/libraries/giflib/4.1.nix
index c70bda034871..941a7c27feaf 100644
--- a/pkgs/development/libraries/giflib/4.1.nix
+++ b/pkgs/development/libraries/giflib/4.1.nix
@@ -10,9 +10,11 @@ stdenv.mkDerivation {
 
   hardeningDisable = [ "format" ];
 
-  meta = {
+  meta = with stdenv.lib; {
+    description = "A library for reading and writing gif images";
     branch = "4.1";
-    platforms = stdenv.lib.platforms.unix;
+    license = licenses.mit;
+    platforms = platforms.unix;
   };
 }
 
diff --git a/pkgs/development/libraries/gio-sharp/default.nix b/pkgs/development/libraries/gio-sharp/default.nix
index 804da49fda93..b0a115eb4a51 100644
--- a/pkgs/development/libraries/gio-sharp/default.nix
+++ b/pkgs/development/libraries/gio-sharp/default.nix
@@ -23,6 +23,8 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "GIO API bindings";
+    homepage = https://github.com/mono/gio-sharp;
+    license = licenses.mit;
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/development/libraries/gnet/default.nix b/pkgs/development/libraries/gnet/default.nix
index c9431420194a..0b2fb9fef6c3 100644
--- a/pkgs/development/libraries/gnet/default.nix
+++ b/pkgs/development/libraries/gnet/default.nix
@@ -17,6 +17,7 @@ stdenv.mkDerivation {
   meta = with stdenv.lib; {
     description = "A network library, written in C, object-oriented, and built upon GLib";
     homepage = https://developer.gnome.org/gnet/;
+    license = licenses.lgpl2;
     platforms = platforms.linux;
     maintainers = with maintainers; [ pSub ];
   };
diff --git a/pkgs/development/libraries/pth/default.nix b/pkgs/development/libraries/pth/default.nix
index 6118d9c41d6f..90dc647233d8 100644
--- a/pkgs/development/libraries/pth/default.nix
+++ b/pkgs/development/libraries/pth/default.nix
@@ -2,7 +2,7 @@
 
 stdenv.mkDerivation rec {
   name = "pth-2.0.7";
-  
+
   src = fetchurl {
     url = "mirror://gnu/pth/${name}.tar.gz";
     sha256 = "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj";
@@ -12,9 +12,10 @@ stdenv.mkDerivation rec {
     configureFlagsArray=("CFLAGS=-DJB_SP=8 -DJB_PC=9")
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "The GNU Portable Threads library";
     homepage = http://www.gnu.org/software/pth;
-    platforms = stdenv.lib.platforms.all;
+    license = licenses.lgpl21Plus;
+    platforms = platforms.all;
   };
 }
diff --git a/pkgs/development/tools/glock/default.nix b/pkgs/development/tools/glock/default.nix
index 98813f143cbb..35f7a2bfdea1 100644
--- a/pkgs/development/tools/glock/default.nix
+++ b/pkgs/development/tools/glock/default.nix
@@ -19,6 +19,7 @@ buildGoPackage rec {
   meta = with stdenv.lib; {
     homepage = https://github.com/robfig/glock;
     description = "A command-line tool to lock Go dependencies to specific revisions";
+    license = licenses.mit;
     maintainers = [ maintainers.rushmorem ];
   };
 }