summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-10-23 14:53:43 +0200
committerRobin Gloster <mail@glob.in>2017-10-24 15:31:52 +0200
commit54a83423f015fc4a8682d76fdc97c3cb16da11dc (patch)
tree76d49a54e066b53e007e5ab1d648bf13373fe8d3 /pkgs/development
parent62ca1c2dab3ebec9dad25492f7274ea262fdbce0 (diff)
downloadnixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.tar
nixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.tar.gz
nixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.tar.bz2
nixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.tar.lz
nixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.tar.xz
nixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.tar.zst
nixlib-54a83423f015fc4a8682d76fdc97c3cb16da11dc.zip
nbconvert: 5.2.1 -> 5.3.1, enable tests
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/nbconvert/default.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/pkgs/development/python-modules/nbconvert/default.nix b/pkgs/development/python-modules/nbconvert/default.nix
index 881895ba6baa..d04e5c5eccbd 100644
--- a/pkgs/development/python-modules/nbconvert/default.nix
+++ b/pkgs/development/python-modules/nbconvert/default.nix
@@ -3,6 +3,7 @@
 , fetchPypi
 , pytest
 , nose
+, glibcLocales
 , entrypoints
 , bleach
 , mistune
@@ -21,15 +22,15 @@
 
 buildPythonPackage rec {
   pname = "nbconvert";
-  version = "5.2.1";
+  version = "5.3.1";
   name = "${pname}-${version}";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "9ed68ec7fe90a8672b43795b29ea91cc75ea355c83debc83ebd12171521ec274";
+    sha256 = "1f9dkvpx186xjm4xab0qbph588mncp4vqk3fmxrsnqs43mks9c8j";
   };
 
-  checkInputs = [ nose pytest ];
+  checkInputs = [ nose pytest glibcLocales ];
 
   propagatedBuildInputs = [
     entrypoints bleach mistune jinja2 pygments traitlets testpath
@@ -37,16 +38,14 @@ buildPythonPackage rec {
   ];
 
   checkPhase = ''
-    nosetests -v
+    mkdir tmp
+    LC_ALL=en_US.utf8 HOME=`realpath tmp` py.test -v
   '';
 
-  # PermissionError. Likely due to being in a chroot
-  doCheck = false;
-
   meta = {
     description = "Converting Jupyter Notebooks";
     homepage = http://jupyter.org/;
     license = lib.licenses.bsd3;
-    maintainers = with lib.maintainers; [ fridh ];
+    maintainers = with lib.maintainers; [ fridh globin ];
   };
 }