summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2018-08-26 14:11:02 +0300
committerJaakko Luttinen <jaakko.luttinen@iki.fi>2018-09-12 08:44:18 +0300
commit541a13ca0ae42dbdea9369c585b51b23b5a660b3 (patch)
tree5837aae2109d050ef48ae4e798f6d0ccd516e021 /pkgs/development
parentc44504410ba5a3bd76a99e7907533779c2b17694 (diff)
downloadnixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.tar
nixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.tar.gz
nixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.tar.bz2
nixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.tar.lz
nixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.tar.xz
nixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.tar.zst
nixlib-541a13ca0ae42dbdea9369c585b51b23b5a660b3.zip
pythonPackages.eth-typing: init at 1.1.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/eth-typing/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/eth-typing/default.nix b/pkgs/development/python-modules/eth-typing/default.nix
new file mode 100644
index 000000000000..070923c83855
--- /dev/null
+++ b/pkgs/development/python-modules/eth-typing/default.nix
@@ -0,0 +1,35 @@
+{ lib, fetchFromGitHub, buildPythonPackage, pythonOlder, pytest }:
+
+buildPythonPackage rec {
+  pname = "eth-typing";
+  version = "1.3.0";
+
+  # Tests are missing from the PyPI source tarball so let's use GitHub
+  # https://github.com/ethereum/eth-typing/issues/8
+  src = fetchFromGitHub {
+    owner = "ethereum";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0703z7vlsfa3dvgcq22f9rzmj0svyp2a8wc7h73d0aac28ydhpv9";
+  };
+
+  # setuptools-markdown uses pypandoc which is broken at the moment
+  preConfigure = ''
+    substituteInPlace setup.py --replace \'setuptools-markdown\' ""
+  '';
+
+  disabled = pythonOlder "3.5";
+
+  checkInputs = [ pytest ];
+
+  checkPhase = ''
+    pytest .
+  '';
+
+  meta = {
+    description = "Common type annotations for Ethereum Python packages";
+    homepage = https://github.com/ethereum/eth-typing;
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ jluttine ];
+  };
+}