summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJudson <nyarly@gmail.com>2018-05-13 14:35:42 -0700
committerJudson <nyarly@gmail.com>2018-05-13 14:35:42 -0700
commit51f4a46af29c4dc47659e687799146a2ac6c04af (patch)
treebc8d05896a182897871b1d5166e57dbacad8e63b /pkgs/development
parent42d0ce8a28c63058004e38d0fb9a1dee4c0d00bc (diff)
downloadnixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.tar
nixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.tar.gz
nixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.tar.bz2
nixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.tar.lz
nixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.tar.xz
nixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.tar.zst
nixlib-51f4a46af29c4dc47659e687799146a2ac6c04af.zip
jira_cli: init at 2.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/jira_cli/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/development/tools/jira_cli/default.nix b/pkgs/development/tools/jira_cli/default.nix
new file mode 100644
index 000000000000..37b76c50e902
--- /dev/null
+++ b/pkgs/development/tools/jira_cli/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, libffi, openssl, pythonPackages }:
+let
+  inherit (pythonPackages) fetchPypi buildPythonApplication vcrpy mock hiro;
+in
+  buildPythonApplication rec {
+    pname = "jira-cli";
+    version = "2.2";
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "314118d5d851394ebf910122fd7ce871f63581393968c71456441eb56be3b112";
+    };
+
+    postPatch = ''
+      substituteInPlace requirements/main.txt --replace "argparse" ""
+    '';
+
+    # Tests rely on VCR cassettes being written during tests. R/O nix store prevents this.
+    doCheck = false;
+    checkInputs = with pythonPackages; [ vcrpy mock hiro ];
+    buildInputs = [ libffi openssl ];
+    propagatedBuildInputs = with pythonPackages; [
+      argparse ordereddict requests six suds-jurko termcolor keyring
+      jira  keyrings-alt
+    ];
+
+    meta = with stdenv.lib; {
+      description = "A command line interface to Jira";
+      homepage = http://github.com/alisaifee/jira-cli;
+      maintainers = with maintainers; [ nyarly ];
+      license = licenses.mit;
+    };
+  }