summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRicardo M. Correia <rcorreia@wizy.org>2014-09-24 00:22:30 +0200
committerRicardo M. Correia <rcorreia@wizy.org>2014-09-29 14:45:55 +0200
commit51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f (patch)
tree9c60f6b5304281e2a6f749ff89f1c101bc030175 /pkgs/development
parentbbdc35d4ddb5f7840182549348e2f5db7f4104ef (diff)
downloadnixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.tar
nixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.tar.gz
nixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.tar.bz2
nixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.tar.lz
nixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.tar.xz
nixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.tar.zst
nixlib-51b8d716f42a0b6bdc3c03e99cda17a3b43ad63f.zip
rustcMaster: Update to a more recent commit
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/rustc/hardcode_paths.HEAD.patch24
-rw-r--r--pkgs/development/compilers/rustc/head.nix21
2 files changed, 26 insertions, 19 deletions
diff --git a/pkgs/development/compilers/rustc/hardcode_paths.HEAD.patch b/pkgs/development/compilers/rustc/hardcode_paths.HEAD.patch
index fea35d24960c..21e6576e4e35 100644
--- a/pkgs/development/compilers/rustc/hardcode_paths.HEAD.patch
+++ b/pkgs/development/compilers/rustc/hardcode_paths.HEAD.patch
@@ -1,8 +1,8 @@
 diff --git a/src/librustc/back/link.rs b/src/librustc/back/link.rs
-index 7a3e912..ced75fa 100644
+index 6332485..9500a23 100644
 --- a/src/librustc/back/link.rs
 +++ b/src/librustc/back/link.rs
-@@ -856,24 +856,15 @@
+@@ -383,18 +383,9 @@ pub fn mangle_internal_name_by_path_and_seq(path: PathElems, flav: &str) -> Stri
  
  pub fn get_cc_prog(sess: &Session) -> String {
      match sess.opts.cg.linker {
@@ -22,11 +22,17 @@ index 7a3e912..ced75fa 100644
 -    }.to_string()
  }
  
- pub fn get_ar_prog(sess: &Session) -> String {
-     match sess.opts.cg.ar {
-         Some(ref ar) => (*ar).clone(),
--        None => "ar".to_string()
-+        None => "@arPath@".to_string()
-     }
- }
+ pub fn remove(sess: &Session, path: &Path) {
+diff --git a/src/librustc_back/archive.rs b/src/librustc_back/archive.rs
+index 060dda5..fecf76b 100644
+--- a/src/librustc_back/archive.rs
++++ b/src/librustc_back/archive.rs
+@@ -53,7 +53,7 @@ fn run_ar(handler: &ErrorHandler, maybe_ar_prog: &Option<String>,
+           paths: &[&Path]) -> ProcessOutput {
+     let ar = match *maybe_ar_prog {
+         Some(ref ar) => ar.as_slice(),
+-        None => "ar"
++        None => "@arPath@"
+     };
+     let mut cmd = Command::new(ar);
  
diff --git a/pkgs/development/compilers/rustc/head.nix b/pkgs/development/compilers/rustc/head.nix
index f3dd7ef3c750..e17f04439a22 100644
--- a/pkgs/development/compilers/rustc/head.nix
+++ b/pkgs/development/compilers/rustc/head.nix
@@ -16,19 +16,19 @@ assert stdenv.gcc.gcc != null;
 
 */
 
-with ((import ./common.nix) {inherit stdenv; version = "0.12.0-pre-79a5448f4"; });
+with ((import ./common.nix) {inherit stdenv; version = "0.12.0-pre-7fbbfe6bf"; });
 
 let snapshot = if stdenv.system == "i686-linux"
-      then "6f5464c9ab191d93bfea0894ca7c6f90c3506f2b"
+      then "5c2132b65f45c21b43d28de6a9460978b1a7b08a"
       else if stdenv.system == "x86_64-linux"
-      then "72c92895fa9a1dba7880073f2b2b5d0e3e1a2ab6"
+      then "152be582853c2cf1ddcc88b085153b52ebbeb065"
       else if stdenv.system == "i686-darwin"
-      then "545fc45a0071142714639c6be377e6d308c3a4e1"
+      then "7adbb076aeae8e1d9bdf3fe968bc7ef8a8fe0096"
       else if stdenv.system == "x86_64-darwin"
-      then "8b44fbbbd1ba519d2e83d0d5ce1f6053d3cab8c6"
+      then "152be582853c2cf1ddcc88b085153b52ebbeb065"
       else abort "no-snapshot for platform ${stdenv.system}";
-    snapshotDate = "2014-09-10";
-    snapshotRev = "6faa4f3";
+    snapshotDate = "2014-09-22";
+    snapshotRev = "437179e";
     snapshotName = "rust-stage0-${snapshotDate}-${snapshotRev}-${platform}-${snapshot}.tar.bz2";
 
 in stdenv.mkDerivation {
@@ -38,8 +38,8 @@ in stdenv.mkDerivation {
 
   src = fetchgit {
     url = https://github.com/rust-lang/rust;
-    rev = "79a5448f41dcc6ab52663105a6b02fc5af4c503e";
-    sha256 = "0v2ahwgb1ls3g4ch6005azjmfh8bs0v0nbmmfpn53zgiiywad2ji";
+    rev = "9a68da7401d9bef645a8b6a4e0ce4cae12604df4";
+    sha256 = "1nrmahz9scv06v8pyfgjl902dh9947irpqi78lh11r5lyixia8ci";
   };
 
   # We need rust to build rust. If we don't provide it, configure will try to download it.
@@ -66,7 +66,8 @@ in stdenv.mkDerivation {
   patches = [ ./hardcode_paths.HEAD.patch ./local_stage0.HEAD.patch ];
   postPatch = ''
     substituteInPlace src/librustc/back/link.rs \
-      --subst-var-by "ccPath" "${stdenv.gcc}/bin/cc" \
+      --subst-var-by "ccPath" "${stdenv.gcc}/bin/cc"
+    substituteInPlace src/librustc_back/archive.rs \
       --subst-var-by "arPath" "${stdenv.gcc.binutils}/bin/ar"
   '';