summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMaxime Dénès <mail@maximedenes.fr>2018-03-07 19:10:17 +0100
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-03-08 08:21:03 +0000
commit50287f8c09c33466974b2ee4dd4c553de881abd0 (patch)
treeba784016e842ef3d640c4d013891236e12df7162 /pkgs/development
parent09fb415c187995e5db7495d0e7c074ca25db0f79 (diff)
downloadnixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.tar
nixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.tar.gz
nixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.tar.bz2
nixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.tar.lz
nixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.tar.xz
nixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.tar.zst
nixlib-50287f8c09c33466974b2ee4dd4c553de881abd0.zip
pythonPackages.antlr4-python3-runtime: init at 4.7.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/antlr4-python3-runtime/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/antlr4-python3-runtime/default.nix b/pkgs/development/python-modules/antlr4-python3-runtime/default.nix
new file mode 100644
index 000000000000..84f2859d50c0
--- /dev/null
+++ b/pkgs/development/python-modules/antlr4-python3-runtime/default.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl, buildPythonPackage, isPy3k }:
+
+buildPythonPackage rec {
+  version = "4.7.1";
+  name = "antlr4-python3-runtime-${version}";
+  disabled = !isPy3k;
+
+  src = fetchurl {
+    url = "mirror://pypi/a/antlr4-python3-runtime/${name}.tar.gz";
+    sha256 = "1lrzmagawmavyw1n1z0qarvs2jmbnbv0p89dah8g7klj8hnbf9hv";
+  };
+
+  meta = {
+    description = "Runtime for ANTLR";
+    homepage = "http://www.antlr.org/";
+    license = stdenv.lib.licenses.bsd3;
+  };
+}