summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJosé Romildo Malaquias <malaquias@gmail.com>2018-08-28 19:19:48 -0300
committerJosé Romildo Malaquias <malaquias@gmail.com>2018-08-28 19:34:20 -0300
commit4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884 (patch)
tree2e05b17d0ede65c7ced1795290e7c8b92d521029 /pkgs/development
parent15780b518cf6cdb3a0a66d603da7842bd8fcec1d (diff)
downloadnixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.tar
nixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.tar.gz
nixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.tar.bz2
nixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.tar.lz
nixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.tar.xz
nixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.tar.zst
nixlib-4f82d135f7e5875e07a3a7b1d6e9a53a6ff12884.zip
pythonefl: move out of python-packages.nix
- Move out of pkgs/top-level/python-packages.nix into
pkgs/development/python-modules/python-efl/default.nix.

- Add dependency on dbus-python.

- Remove hardeningDisable.

- Update some meta attributes.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/python-efl/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/python-efl/default.nix b/pkgs/development/python-modules/python-efl/default.nix
new file mode 100644
index 000000000000..b1696a11f77b
--- /dev/null
+++ b/pkgs/development/python-modules/python-efl/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchurl, buildPythonPackage, pkgconfig, python, enlightenment }:
+
+# Should be bumped along with EFL!
+
+buildPythonPackage rec {
+  name = "python-efl-${version}";
+  version = "1.21.0";
+
+  src = fetchurl {
+    url = "http://download.enlightenment.org/rel/bindings/python/${name}.tar.xz";
+    sha256 = "08x2cv8hnf004c3711250wrax21ffj5y8951pvk77h98als4pq47";
+  };
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  buildInputs = [ enlightenment.efl ];
+
+  propagatedBuildInputs = [ python.pkgs.dbus-python ];
+
+  preConfigure = ''
+    export NIX_CFLAGS_COMPILE="$(pkg-config --cflags efl) -I${python.pkgs.dbus-python}/include/dbus-1.0 $NIX_CFLAGS_COMPILE"
+  '';
+  
+  preBuild = "${python}/bin/${python.executable} setup.py build_ext";
+
+  installPhase= "${python}/bin/${python.executable} setup.py install --prefix=$out";
+
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    description = "Python bindings for EFL and Elementary";
+    homepage = https://phab.enlightenment.org/w/projects/python_bindings_for_efl/;
+    platforms = platforms.linux;
+    license = with licenses; [ gpl3 lgpl3 ];
+    maintainers = with maintainers; [ matejc tstrobel ftrvxmtrx ];
+  };
+}