summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-27 01:02:25 +0100
committerRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-27 01:02:25 +0100
commit4e50deb14ae7577dbad0b6983f73c3e4aa05c057 (patch)
treee92abb2e96bfb87e0594372156394f4f2f74c50c /pkgs/development
parent31a94650e2a3be50fce643436c8252e7ee396b90 (diff)
downloadnixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.tar
nixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.tar.gz
nixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.tar.bz2
nixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.tar.lz
nixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.tar.xz
nixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.tar.zst
nixlib-4e50deb14ae7577dbad0b6983f73c3e4aa05c057.zip
yq: add xmltodict dependency
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/yq/default.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/pkgs/development/tools/yq/default.nix b/pkgs/development/tools/yq/default.nix
index 3283136590af..c911cdb58250 100644
--- a/pkgs/development/tools/yq/default.nix
+++ b/pkgs/development/tools/yq/default.nix
@@ -1,11 +1,10 @@
-{ stdenv, lib, buildPythonApplication, fetchPypi, pyyaml, jq }:
+{ stdenv, lib, buildPythonApplication, fetchPypi, pyyaml, xmltodict, jq }:
 
 buildPythonApplication rec {
-
   pname = "yq";
   version = "2.4.1";
 
-  propagatedBuildInputs = [ pyyaml jq ];
+  propagatedBuildInputs = [ pyyaml xmltodict jq ];
 
   # ValueError: underlying buffer has been detached
   doCheck = false;
@@ -17,9 +16,8 @@ buildPythonApplication rec {
 
   meta = with lib; {
     description = "Command-line YAML processor - jq wrapper for YAML documents.";
-    homepage = https://pypi.python.org/pypi/yq;
+    homepage = https://github.com/kislyuk/yq;
     license = [ licenses.asl20 ];
     maintainers = [ maintainers.womfoo ];
   };
-
 }