summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-02-04 12:35:01 +0000
committerGitHub <noreply@github.com>2018-02-04 12:35:01 +0000
commit4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba (patch)
tree2223adc55eff86c6e65ac20c72cf41615412438a /pkgs/development
parent2dcb7573d9a2d500d9a9adbb05d1a381ddb2d13c (diff)
parent411cd15e59583dd6f1519ae9848f11f43ed5bd89 (diff)
downloadnixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.tar
nixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.tar.gz
nixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.tar.bz2
nixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.tar.lz
nixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.tar.xz
nixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.tar.zst
nixlib-4cb79ee66e6cfcc8c5f4ff9e3a2dce5bb2b8b5ba.zip
Merge pull request #34573 from dotlambda/luftdaten
python3Packages.luftdaten: init at 0.1.4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/luftdaten/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/luftdaten/default.nix b/pkgs/development/python-modules/luftdaten/default.nix
new file mode 100644
index 000000000000..dc40101284c0
--- /dev/null
+++ b/pkgs/development/python-modules/luftdaten/default.nix
@@ -0,0 +1,25 @@
+{ lib, buildPythonPackage, isPy3k, fetchPypi, aiohttp, async-timeout }:
+
+buildPythonPackage rec {
+  pname = "luftdaten";
+  version = "0.1.4";
+
+  disabled = !isPy3k;
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "d3e3af830ad2b731c36af223bbb5d47d68aa3786b2965411216917a7381e1179";
+  };
+
+  propagatedBuildInputs = [ aiohttp async-timeout ];
+
+  # No tests implemented
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Python API for interacting with luftdaten.info";
+    homepage = https://github.com/fabaff/python-luftdaten;
+    license = licenses.mit;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}