summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-07-05 22:17:14 -0400
committerGitHub <noreply@github.com>2018-07-05 22:17:14 -0400
commit4bbca076ea77dff191e9b9a14e487f5ae579d776 (patch)
tree0a09f7cbb173fe99196d862316436fd9bd5f5579 /pkgs/development
parent7f50e0a6869bbb5578f2afcb3cad24cb3442aee0 (diff)
parent722dd05b140504eb2727e55054485b4f003872d0 (diff)
downloadnixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.tar
nixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.tar.gz
nixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.tar.bz2
nixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.tar.lz
nixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.tar.xz
nixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.tar.zst
nixlib-4bbca076ea77dff191e9b9a14e487f5ae579d776.zip
Merge pull request #42529 from mkaito/mesa-pkgconfig
mesa: point pkgconfig at $drivers
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/mesa/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/development/libraries/mesa/default.nix b/pkgs/development/libraries/mesa/default.nix
index f8152bea2cc1..87a4833b7788 100644
--- a/pkgs/development/libraries/mesa/default.nix
+++ b/pkgs/development/libraries/mesa/default.nix
@@ -205,6 +205,11 @@ let self = stdenv.mkDerivation {
     for js in $drivers/share/glvnd/egl_vendor.d/*.json; do
       substituteInPlace "$js" --replace '"libEGL_' '"'"$drivers/lib/libEGL_"
     done
+
+    # Update search path used by pkg-config
+    for pc in $dev/lib/pkgconfig/*.pc; do
+      substituteInPlace "$pc" --replace $out $drivers
+    done
   '' + optionalString (vulkanDrivers != []) ''
     # Update search path used by Vulkan (it's pointing to $out but
     # drivers are in $drivers)