summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2017-09-16 13:06:12 +0100
committerJörg Thalheim <joerg@thalheim.io>2017-09-16 13:06:12 +0100
commit46c30b2232fe2c903d07a0b35ac79cd6ba6935c5 (patch)
tree4e1cb3a17a990247749f8ced037cd99a61b124ca /pkgs/development
parent755e6eb22e6b8c528006fee70a6bfd3fa352c2c3 (diff)
downloadnixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.tar
nixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.tar.gz
nixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.tar.bz2
nixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.tar.lz
nixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.tar.xz
nixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.tar.zst
nixlib-46c30b2232fe2c903d07a0b35ac79cd6ba6935c5.zip
python.pkgs.hcs_utils: fix tests; disable python2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/hcs_utils/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/development/python-modules/hcs_utils/default.nix b/pkgs/development/python-modules/hcs_utils/default.nix
index 785b9ddd04ba..cfaaa5636113 100644
--- a/pkgs/development/python-modules/hcs_utils/default.nix
+++ b/pkgs/development/python-modules/hcs_utils/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildPythonPackage, fetchPypi, six, glibcLocales, pytest }:
+{ stdenv, pythonOlder, buildPythonPackage, fetchPypi, six, glibcLocales, pytest }:
 
 buildPythonPackage rec {
   pname = "hcs_utils";
@@ -12,7 +12,15 @@ buildPythonPackage rec {
 
   LC_ALL="en_US.UTF-8";
 
-  buildInputs = [ six glibcLocales pytest ];
+  checkPhase = ''
+    # root does not has /root as home in sandbox
+    py.test -k 'not test_expand' hcs_utils/test
+  '';
+
+  buildInputs = [ six glibcLocales ];
+  checkInputs = [ pytest ];
+
+  disabled = pythonOlder "3.4";
 
   meta = with stdenv.lib; {
     description = "Library collecting some useful snippets";