summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-03 23:22:26 +0100
committerRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-03 23:22:26 +0100
commit411cd15e59583dd6f1519ae9848f11f43ed5bd89 (patch)
treedc6899b00f72a970fe3ed78bbb672721456fc4a5 /pkgs/development
parent93be6c41aa742b045a3d823814f72378a2f37d2a (diff)
downloadnixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.tar
nixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.tar.gz
nixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.tar.bz2
nixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.tar.lz
nixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.tar.xz
nixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.tar.zst
nixlib-411cd15e59583dd6f1519ae9848f11f43ed5bd89.zip
python3Packages.luftdaten: init at 0.1.4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/luftdaten/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/luftdaten/default.nix b/pkgs/development/python-modules/luftdaten/default.nix
new file mode 100644
index 000000000000..dc40101284c0
--- /dev/null
+++ b/pkgs/development/python-modules/luftdaten/default.nix
@@ -0,0 +1,25 @@
+{ lib, buildPythonPackage, isPy3k, fetchPypi, aiohttp, async-timeout }:
+
+buildPythonPackage rec {
+  pname = "luftdaten";
+  version = "0.1.4";
+
+  disabled = !isPy3k;
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "d3e3af830ad2b731c36af223bbb5d47d68aa3786b2965411216917a7381e1179";
+  };
+
+  propagatedBuildInputs = [ aiohttp async-timeout ];
+
+  # No tests implemented
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Python API for interacting with luftdaten.info";
+    homepage = https://github.com/fabaff/python-luftdaten;
+    license = licenses.mit;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}