summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDing Xiang Fei <dingxiangfei2009@gmail.com>2018-07-31 11:24:11 +0800
committerDing Xiang Fei <dingxiangfei2009@gmail.com>2018-07-31 11:24:11 +0800
commit40c2bf6e42c342a78a32399e9391513cba8522e4 (patch)
treec7bf829468182713b38cafc29486765d72559d94 /pkgs/development
parent003055a670470f678e376be7f9b9051fb242ec0f (diff)
parent7ae2ba173f3938170778d1a913e415e2ff78c9e6 (diff)
downloadnixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.tar
nixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.tar.gz
nixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.tar.bz2
nixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.tar.lz
nixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.tar.xz
nixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.tar.zst
nixlib-40c2bf6e42c342a78a32399e9391513cba8522e4.zip
Merge branch 'master' into cross-compiling-postgresql
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix7
-rw-r--r--pkgs/development/interpreters/php/default.nix4
-rw-r--r--pkgs/development/libraries/jsonrpc-glib/default.nix40
-rw-r--r--pkgs/development/libraries/msgpuck/default.nix25
-rw-r--r--pkgs/development/libraries/ptex/default.nix4
-rw-r--r--pkgs/development/libraries/rdkafka/default.nix4
-rw-r--r--pkgs/development/libraries/talloc/default.nix4
-rw-r--r--pkgs/development/libraries/template-glib/default.nix36
-rw-r--r--pkgs/development/libraries/xapian/default.nix9
-rw-r--r--pkgs/development/libraries/xapian/fix-notmuch-tagging.patch31
-rw-r--r--pkgs/development/python-modules/contextvars/default.nix4
-rw-r--r--pkgs/development/python-modules/easygui/default.nix20
-rw-r--r--pkgs/development/python-modules/fluent-logger/default.nix22
-rw-r--r--pkgs/development/python-modules/gphoto2/default.nix26
-rw-r--r--pkgs/development/python-modules/libusb1/default.nix6
-rw-r--r--pkgs/development/python-modules/pymediainfo/default.nix42
-rw-r--r--pkgs/development/python-modules/pyprind/default.nix28
-rw-r--r--pkgs/development/python-modules/pytest-flake8/default.nix9
-rw-r--r--pkgs/development/python-modules/rawkit/default.nix28
-rw-r--r--pkgs/development/python-modules/reportlab/default.nix11
-rw-r--r--pkgs/development/tools/analysis/rr/default.nix2
-rw-r--r--pkgs/development/tools/aws-sam-cli/default.nix11
-rw-r--r--pkgs/development/tools/build-managers/sbt/default.nix4
-rw-r--r--pkgs/development/tools/golangci-lint/default.nix24
-rw-r--r--pkgs/development/tools/jq/default.nix9
-rw-r--r--pkgs/development/tools/skopeo/default.nix4
26 files changed, 383 insertions, 31 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 3c8f94860b40..8c1c2fac2507 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -972,6 +972,13 @@ self: super: {
     sha256 = "0i889zs46wn09d7iqdy99201zaqxb175cfs8jz2zi3mv4ywx3a0l";
   });
 
+  # https://github.com/simonmichael/hledger/issues/852
+  hledger-lib = appendPatch super.hledger-lib (pkgs.fetchpatch {
+    url = "https://github.com/simonmichael/hledger/commit/007b9f8caaf699852511634752a7d7c86f6adc67.patch";
+    sha256 = "1lfp29mi1qyrcr9nfjigbyric0xb9n4ann5w6sr0g5sanr4maqs2";
+    stripLen = 1;
+  });
+
   # Copy hledger man pages from data directory into the proper place. This code
   # should be moved into the cabal2nix generator.
   hledger = overrideCabal super.hledger (drv: {
diff --git a/pkgs/development/interpreters/php/default.nix b/pkgs/development/interpreters/php/default.nix
index a77ee4256179..cc50edecf602 100644
--- a/pkgs/development/interpreters/php/default.nix
+++ b/pkgs/development/interpreters/php/default.nix
@@ -231,8 +231,8 @@ in {
   };
 
   php71 = generic {
-    version = "7.1.19";
-    sha256 = "1wvhsxzmb78pcr36ginz93iv7rcrxp3p01rb34zxa2h4wdxkxi0k";
+    version = "7.1.20";
+    sha256 = "0i8xd6p4zdg8fl6f0j430raanlshsshr3s3jlm72b0gvi1n4f6rs";
   };
 
   php72 = generic {
diff --git a/pkgs/development/libraries/jsonrpc-glib/default.nix b/pkgs/development/libraries/jsonrpc-glib/default.nix
new file mode 100644
index 000000000000..a73122d8253e
--- /dev/null
+++ b/pkgs/development/libraries/jsonrpc-glib/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, meson, ninja, glib, json-glib, pkgconfig, gobjectIntrospection, vala, gtk-doc, docbook_xsl, docbook_xml_dtd_43, gnome3 }:
+let
+  version = "3.28.1";
+  pname = "jsonrpc-glib";
+in
+stdenv.mkDerivation {
+  name = "${pname}-${version}";
+
+  outputs = [ "out" "dev" "devdoc" ];
+
+  nativeBuildInputs = [ meson ninja pkgconfig gobjectIntrospection vala gtk-doc docbook_xsl docbook_xml_dtd_43 ];
+  buildInputs = [ glib json-glib ];
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/${pname}/${stdenv.lib.versions.majorMinor version}/${pname}-${version}.tar.xz";
+    sha256 = "0avff2ldjvwrb8rnzlgslagdjf6x7bmdx69rsq20k6f38icw4ang";
+  };
+
+  mesonFlags = [
+    "-Denable_gtk_doc=true"
+  ];
+
+  # Tests fail non-deterministically
+  # https://gitlab.gnome.org/GNOME/jsonrpc-glib/issues/2
+  doCheck = false;
+
+  passthru = {
+    updateScript = gnome3.updateScript {
+      packageName = pname;
+    };
+  };
+
+  meta = with stdenv.lib; {
+    description = "A library to communicate using the JSON-RPC 2.0 specification";
+    homepage = https://gitlab.gnome.org/GNOME/jsonrpc-glib;
+    license = licenses.lgpl21Plus;
+    maintainers = gnome3.maintainers;
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/development/libraries/msgpuck/default.nix b/pkgs/development/libraries/msgpuck/default.nix
new file mode 100644
index 000000000000..e177694e894e
--- /dev/null
+++ b/pkgs/development/libraries/msgpuck/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, cmake, pkgconfig }:
+
+stdenv.mkDerivation rec {
+  name = "msgpuck-${version}";
+  version = "2.0";
+
+  src = fetchFromGitHub {
+    owner = "rtsisyk";
+    repo = "msgpuck";
+    rev = "${version}";
+    sha256 = "0cjq86kncn3lv65vig9cqkqqv2p296ymcjjbviw0j1s85cfflps0";
+  };
+
+  outputs = [ "out" "dev" ];
+
+  nativeBuildInputs = [ cmake pkgconfig ];
+
+  meta = with stdenv.lib; {
+     description = ''A simple and efficient MsgPack binary serialization library in a self-contained header file'';
+     homepage = https://github.com/rtsisyk/msgpuck;
+     license = licenses.bsd2;
+     platforms = platforms.linux;
+     maintainers = with maintainers; [ izorkin ];
+ };
+}
diff --git a/pkgs/development/libraries/ptex/default.nix b/pkgs/development/libraries/ptex/default.nix
index f300a571b0cc..aa17771ec9f2 100644
--- a/pkgs/development/libraries/ptex/default.nix
+++ b/pkgs/development/libraries/ptex/default.nix
@@ -3,13 +3,13 @@
 stdenv.mkDerivation rec
 {
   name = "ptex-${version}";
-  version = "2.1.33";
+  version = "2.3.0";
 
   src = fetchFromGitHub {
     owner = "wdas";
     repo = "ptex";
     rev = "v${version}";
-    sha256 = "15ijjq3w7hwgm4mqah0x4jzjy3v2nnmmv28lbqzmxzcxjgh4sjkn";
+    sha256 = "0nfz0y66bmi6xckn1whi4sfd8i3ibln212fgm4img2z98b6vccyg";
   };
 
   outputs = [ "bin" "dev" "out" "lib" ];
diff --git a/pkgs/development/libraries/rdkafka/default.nix b/pkgs/development/libraries/rdkafka/default.nix
index a1af43748430..11ae3a52adce 100644
--- a/pkgs/development/libraries/rdkafka/default.nix
+++ b/pkgs/development/libraries/rdkafka/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "rdkafka-${version}";
-  version = "0.11.4";
+  version = "0.11.5";
 
   src = fetchFromGitHub {
     owner = "edenhill";
     repo = "librdkafka";
     rev = "v${version}";
-    sha256 = "11ps8sy4v8yvj4sha7d1q3rmhfw7l1rd52rnl01xam9862yasahs";
+    sha256 = "1b0zp7k0775g5pzvkmpmsha63wx8wcwcas6w6wb09y0gymxz0xss";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/development/libraries/talloc/default.nix b/pkgs/development/libraries/talloc/default.nix
index 30d9a38a35df..77c3c6458ade 100644
--- a/pkgs/development/libraries/talloc/default.nix
+++ b/pkgs/development/libraries/talloc/default.nix
@@ -3,11 +3,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "talloc-2.1.13";
+  name = "talloc-2.1.14";
 
   src = fetchurl {
     url = "mirror://samba/talloc/${name}.tar.gz";
-    sha256 = "0iv09iv385x69gfzvassq6m3y0rd8ncylls95dm015xdy3drkww4";
+    sha256 = "1kk76dyav41ip7ddbbf04yfydb4jvywzi2ps0z2vla56aqkn11di";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/development/libraries/template-glib/default.nix b/pkgs/development/libraries/template-glib/default.nix
new file mode 100644
index 000000000000..6ce02d588a97
--- /dev/null
+++ b/pkgs/development/libraries/template-glib/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, meson, ninja, pkgconfig, glib, gobjectIntrospection, flex, bison, vala, gettext, gnome3, gtk-doc, docbook_xsl, docbook_xml_dtd_43 }:
+let
+  version = "3.28.0";
+  pname = "template-glib";
+in
+stdenv.mkDerivation {
+  name = "${pname}-${version}";
+
+  outputs = [ "out" "dev" "devdoc" ];
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/${pname}/${stdenv.lib.versions.majorMinor version}/${pname}-${version}.tar.xz";
+    sha256 = "18bic41f9cx8h6n5bz80z4ridb8c1h1yscicln8zsn23zmp44x3c";
+  };
+
+  buildInputs = [ meson ninja pkgconfig gettext flex bison vala glib gtk-doc docbook_xsl docbook_xml_dtd_43 ];
+  nativeBuildInputs = [ glib gobjectIntrospection ];
+
+  mesonFlags = [
+    "-Denable_gtk_doc=true"
+  ];
+
+  passthru = {
+    updateScript = gnome3.updateScript {
+      packageName = pname;
+    };
+  };
+
+  meta = with stdenv.lib; {
+    description = "A library for template expansion which supports calling into GObject Introspection from templates";
+    homepage = https://gitlab.gnome.org/GNOME/template-glib;
+    license = licenses.lgpl21Plus;
+    maintainers = gnome3.maintainers;
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/development/libraries/xapian/default.nix b/pkgs/development/libraries/xapian/default.nix
index 5dd81af2b1af..8c0d065247b4 100644
--- a/pkgs/development/libraries/xapian/default.nix
+++ b/pkgs/development/libraries/xapian/default.nix
@@ -11,6 +11,13 @@ let
       inherit sha256;
     };
 
+    patches = [
+      # fix notmuch build, see https://notmuchmail.org/faq/#index12h2
+      # cannot fetchpatch this because base directory differs
+      # TODO: remove on next xapian update
+      ./fix-notmuch-tagging.patch
+    ];
+
     outputs = [ "out" "man" "doc" ];
 
     buildInputs = [ libuuid zlib ];
@@ -36,5 +43,5 @@ let
 in {
   # xapian-ruby needs 1.2.22 as of 2017-05-06
   xapian_1_2_22 = generic "1.2.22" "0zsji22n0s7cdnbgj0kpil05a6bgm5cfv0mvx12d8ydg7z58g6r6";
-  xapian_1_4 = generic "1.4.5" "0axhqrj202hbll9mcx1qdm8gsqj19216w3z02gyjbycxvr9gkdc5";
+  xapian_1_4 = generic "1.4.7" "1lxmlds3v5s1gng9nk1rvmln1zcksrw5ds509y0glylwch5qmw0k";
 }
diff --git a/pkgs/development/libraries/xapian/fix-notmuch-tagging.patch b/pkgs/development/libraries/xapian/fix-notmuch-tagging.patch
new file mode 100644
index 000000000000..6deae76d2aa7
--- /dev/null
+++ b/pkgs/development/libraries/xapian/fix-notmuch-tagging.patch
@@ -0,0 +1,31 @@
+From f9e6f45b1c8f66bca8a3387f371b20d434b23a7d Mon Sep 17 00:00:00 2001
+From: Olly Betts <olly@survex.com>
+Date: Thu, 26 Jul 2018 17:26:52 +1200
+Subject: [PATCH 1/1] Revert "Enable open_nearby_postlist for writable
+ databases"
+
+The amended check isn't conservative enough as there may be postlist
+changes in the inverter while the table is unmodified.  This breaks
+testcase T150-tagging.sh in notmuch's testsuite, reported by David
+Bremner.
+
+This reverts commit 5489fb2f838c0f0b0a593b4c17df282a93a1fe5a.
+---
+ xapian-core/backends/glass/glass_postlist.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xapian-core/backends/glass/glass_postlist.cc b/xapian-core/backends/glass/glass_postlist.cc
+index 80e578b85..a47f14a68 100644
+--- a/backends/glass/glass_postlist.cc
++++ b/backends/glass/glass_postlist.cc
+@@ -759,7 +759,7 @@ GlassPostList::open_nearby_postlist(const std::string & term_,
+     (void)need_pos;
+     if (term_.empty())
+ 	RETURN(NULL);
+-    if (!this_db.get() || this_db->postlist_table.is_modified())
++    if (!this_db.get() || this_db->postlist_table.is_writable())
+ 	RETURN(NULL);
+     RETURN(new GlassPostList(this_db, term_, cursor->clone()));
+ }
+-- 
+2.11.0
diff --git a/pkgs/development/python-modules/contextvars/default.nix b/pkgs/development/python-modules/contextvars/default.nix
index d8ee3b1ca9ef..12914617b8f5 100644
--- a/pkgs/development/python-modules/contextvars/default.nix
+++ b/pkgs/development/python-modules/contextvars/default.nix
@@ -2,12 +2,12 @@
 
 buildPythonPackage rec {
   pname = "contextvars";
-  version = "2.2";
+  version = "2.3";
   disabled = !isPy36;
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "046b385nfzkjh0wqmd268p2jkgn9fg6hz40npq7j1w3c8aqzhwvx";
+    sha256 = "09fnni8cyxm070bfv9ay030qbyk0dfds5nq77s0p38h33hp08h93";
   };
 
   propagatedBuildInputs = [ immutables ];
diff --git a/pkgs/development/python-modules/easygui/default.nix b/pkgs/development/python-modules/easygui/default.nix
new file mode 100644
index 000000000000..3a7046c50b30
--- /dev/null
+++ b/pkgs/development/python-modules/easygui/default.nix
@@ -0,0 +1,20 @@
+{ stdenv, fetchPypi, buildPythonPackage }:
+
+buildPythonPackage rec {
+  pname = "easygui";
+  version = "0.98.1";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1zmvmwgxyzvm83818skhn8b4wrci4kmnixaax8q3ia5cn7xrmj6v";
+  };
+
+  doCheck = false; # No tests available
+
+  meta = with stdenv.lib; {
+    description = "Very simple, very easy GUI programming in Python";
+    homepage = https://github.com/robertlugg/easygui;
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ jfrankenau ];
+  };
+}
diff --git a/pkgs/development/python-modules/fluent-logger/default.nix b/pkgs/development/python-modules/fluent-logger/default.nix
new file mode 100644
index 000000000000..8af0bce82f3c
--- /dev/null
+++ b/pkgs/development/python-modules/fluent-logger/default.nix
@@ -0,0 +1,22 @@
+{ lib, buildPythonPackage, fetchPypi, msgpack }:
+
+buildPythonPackage rec {
+  pname = "fluent-logger";
+  version = "0.9.3";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "09vii0iclfq6vhz37xyybksq9m3538hkr7z40sz2dlpf2rkg98mg";
+  };
+
+  propagatedBuildInputs = [ msgpack ];
+  
+  # Tests fail because absent in package
+  doCheck = false;
+
+  meta = with lib; {
+    description = "A structured logger for Fluentd (Python)";
+    homepage = https://github.com/fluent/fluent-logger-python;
+    license = licenses.asl20;
+  };
+}
diff --git a/pkgs/development/python-modules/gphoto2/default.nix b/pkgs/development/python-modules/gphoto2/default.nix
new file mode 100644
index 000000000000..29aa0400ec57
--- /dev/null
+++ b/pkgs/development/python-modules/gphoto2/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchPypi, buildPythonPackage
+, pkgconfig
+, libgphoto2 }:
+
+buildPythonPackage rec {
+  pname = "gphoto2";
+  version = "1.8.2";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1806bdjc18qh0wyayxymgjnqqqlxs2iwvgk594anxw9y69hrxqni";
+  };
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  buildInputs = [ libgphoto2 ];
+
+  doCheck = false; # No tests available
+
+  meta = with stdenv.lib; {
+    description = "Python interface to libgphoto2";
+    homepage = https://github.com/jim-easterbrook/python-gphoto2;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ jfrankenau ];
+  };
+}
diff --git a/pkgs/development/python-modules/libusb1/default.nix b/pkgs/development/python-modules/libusb1/default.nix
index 8d74a4d3c46e..f11930a3a18d 100644
--- a/pkgs/development/python-modules/libusb1/default.nix
+++ b/pkgs/development/python-modules/libusb1/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, buildPythonPackage, fetchPypi, libusb1 }:
+{ stdenv, lib, buildPythonPackage, fetchPypi, python, libusb1 }:
 
 buildPythonPackage rec {
   pname = "libusb1";
@@ -17,6 +17,10 @@ buildPythonPackage rec {
 
   buildInputs = [ libusb1 ];
 
+  checkPhase = ''
+    ${python.interpreter} -m usb1.testUSB1
+  '';
+
   meta = with stdenv.lib; {
     homepage    = https://github.com/vpelletier/python-libusb1;
     description = "Python ctype-based wrapper around libusb1";
diff --git a/pkgs/development/python-modules/pymediainfo/default.nix b/pkgs/development/python-modules/pymediainfo/default.nix
new file mode 100644
index 000000000000..3245c3d3c48f
--- /dev/null
+++ b/pkgs/development/python-modules/pymediainfo/default.nix
@@ -0,0 +1,42 @@
+{ stdenv, fetchPypi, buildPythonPackage
+, libmediainfo
+, setuptools_scm
+, pytest, glibcLocales }:
+
+buildPythonPackage rec {
+  pname = "pymediainfo";
+  version = "2.3.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1d0mxxycacimy46b08q44xyxkyji7rrs7viwc3wkpckhqs54q24x";
+  };
+
+  postPatch = ''
+    substituteInPlace pymediainfo/__init__.py \
+      --replace 'CDLL(library_file)' \
+                'CDLL("${libmediainfo}/lib/libmediainfo${stdenv.hostPlatform.extensions.sharedLibrary}")' \
+      --replace 'CDLL("libmediainfo.0.dylib")' \
+                'CDLL("${libmediainfo}/lib/libmediainfo.0${stdenv.hostPlatform.extensions.sharedLibrary}")' \
+      --replace 'CDLL("libmediainfo.dylib")' \
+                'CDLL("${libmediainfo}/lib/libmediainfo${stdenv.hostPlatform.extensions.sharedLibrary}")' \
+      --replace 'CDLL("libmediainfo.so.0")' \
+                'CDLL("${libmediainfo}/lib/libmediainfo${stdenv.hostPlatform.extensions.sharedLibrary}.0")'
+  '';
+
+  nativeBuildInputs = [ setuptools_scm ];
+
+  checkInputs = [ glibcLocales pytest ];
+
+  checkPhase = ''
+    export LC_ALL=en_US.UTF-8
+    py.test -k 'not test_parse_url' tests
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Python wrapper for the mediainfo library";
+    homepage = https://github.com/sbraz/pymediainfo;
+    license = licenses.mit;
+    maintainers = with maintainers; [ jfrankenau ];
+  };
+}
diff --git a/pkgs/development/python-modules/pyprind/default.nix b/pkgs/development/python-modules/pyprind/default.nix
new file mode 100644
index 000000000000..de1b17be739d
--- /dev/null
+++ b/pkgs/development/python-modules/pyprind/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchPypi, buildPythonPackage
+, psutil
+, pytest }:
+
+buildPythonPackage rec {
+  pname = "PyPrind";
+  version = "2.11.2";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0xg6m5hr33h9bdlrr42kc58jm2m87a9zsagy7n2m4n407d2snv64";
+  };
+
+  buildInputs = [ psutil ];
+
+  checkInputs = [ pytest ];
+
+  checkPhase = ''
+    py.test tests
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Python Progress Bar and Percent Indicator Utility";
+    homepage = https://github.com/rasbt/pyprind;
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ jfrankenau ];
+  };
+}
diff --git a/pkgs/development/python-modules/pytest-flake8/default.nix b/pkgs/development/python-modules/pytest-flake8/default.nix
index 2ad44c4e8066..558fe32b909d 100644
--- a/pkgs/development/python-modules/pytest-flake8/default.nix
+++ b/pkgs/development/python-modules/pytest-flake8/default.nix
@@ -2,7 +2,7 @@
 
 buildPythonPackage rec {
   pname = "pytest-flake8";
-  version = "1.0.1";
+  version = "1.0.2";
 
   # although pytest is a runtime dependency, do not add it as
   # propagatedBuildInputs in order to allow packages depend on another version
@@ -12,16 +12,13 @@ buildPythonPackage rec {
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "0s5fdivrmhjf6ybr6m2qb1h8hndv2jh2ir29qv36lhy9b7sc9kg5";
+    sha256 = "c740ad6aa19e3958947d2118f70bed218caf1d2097039fb7318573a2a72f89a1";
   };
 
   checkPhase = ''
-    pytest . -k "not test_mtime_caching"
+    pytest .
   '';
 
-  # https://github.com/tholo/pytest-flake8/issues/49
-  doCheck = false;
-
   meta = {
     description = "py.test plugin for efficiently checking PEP8 compliance";
     homepage = https://github.com/tholo/pytest-flake8;
diff --git a/pkgs/development/python-modules/rawkit/default.nix b/pkgs/development/python-modules/rawkit/default.nix
new file mode 100644
index 000000000000..e8be12b26696
--- /dev/null
+++ b/pkgs/development/python-modules/rawkit/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchPypi, buildPythonPackage
+, libraw
+, pytest, mock }:
+
+buildPythonPackage rec {
+  pname = "rawkit";
+  version = "0.6.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0vrhrpr70i61y5q5ysk341x1539ff1q1k82g59zq69lv16s0f76s";
+  };
+
+  buildInputs = [ libraw ];
+
+  checkInputs = [ pytest mock ];
+
+  checkPhase = ''
+    py.test tests
+  '';
+
+  meta = with stdenv.lib; {
+    description = "CTypes based LibRaw bindings for Python";
+    homepage = https://rawkit.readthedocs.org/;
+    license = licenses.mit;
+    maintainers = with maintainers; [ jfrankenau ];
+  };
+}
diff --git a/pkgs/development/python-modules/reportlab/default.nix b/pkgs/development/python-modules/reportlab/default.nix
index 6ede1b8937b5..298c3c79e387 100644
--- a/pkgs/development/python-modules/reportlab/default.nix
+++ b/pkgs/development/python-modules/reportlab/default.nix
@@ -23,12 +23,17 @@ in buildPythonPackage rec {
   buildInputs = [ ft pillow ];
 
   postPatch = ''
-    rm tests/test_graphics_barcode.py
+    # Remove all the test files that require access to the internet to pass.
+    rm tests/test_lib_utils.py
+    rm tests/test_platypus_general.py
+
+    # Remove the tests that require Vera fonts installed
     rm tests/test_graphics_render.py
   '';
 
   checkPhase = ''
-    LC_ALL="en_US.UTF-8" ${python.interpreter} tests/runAll.py
+    cd tests
+    LC_ALL="en_US.UTF-8" ${python.interpreter} runAll.py
   '';
 
   # See https://bitbucket.org/pypy/compatibility/wiki/reportlab%20toolkit
@@ -38,4 +43,4 @@ in buildPythonPackage rec {
     description = "An Open Source Python library for generating PDFs and graphics";
     homepage = http://www.reportlab.com/;
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/development/tools/analysis/rr/default.nix b/pkgs/development/tools/analysis/rr/default.nix
index d0d20362236b..9c2419b53589 100644
--- a/pkgs/development/tools/analysis/rr/default.nix
+++ b/pkgs/development/tools/analysis/rr/default.nix
@@ -51,6 +51,6 @@ stdenv.mkDerivation rec {
 
     license = "custom";
     maintainers = with stdenv.lib.maintainers; [ pierron thoughtpolice ];
-    platforms = ["x86_64-linux"];
+    platforms = stdenv.lib.platforms.x86;
   };
 }
diff --git a/pkgs/development/tools/aws-sam-cli/default.nix b/pkgs/development/tools/aws-sam-cli/default.nix
index e33d6b26b12b..8778084163e8 100644
--- a/pkgs/development/tools/aws-sam-cli/default.nix
+++ b/pkgs/development/tools/aws-sam-cli/default.nix
@@ -6,11 +6,11 @@ with python.pkgs;
 
 buildPythonApplication rec {
   pname = "aws-sam-cli";
-  version = "0.4.0";
+  version = "0.5.0";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "4740bfa23f39880d807aa75a2143259f7f15eec34c5fa5dde8fc04d8563ef521";
+    sha256 = "2acf9517f467950adb4939746658091e60cf60ee80093ffd0d3d821cb8a1f9fc";
   };
 
   # Tests are not included in the PyPI package
@@ -21,13 +21,20 @@ buildPythonApplication rec {
     boto3
     click
     cookiecutter
+    dateparser
     docker
     enum34
     flask
+    python-dateutil
     pyyaml
     six
   ];
 
+  postPatch = ''
+    substituteInPlace ./requirements/base.txt \
+      --replace 'aws-sam-translator==1.6.0' 'aws-sam-translator>=1.6.0';
+  '';
+
   meta = with lib; {
     homepage = https://github.com/awslabs/aws-sam-cli;
     description = "CLI tool for local development and testing of Serverless applications";
diff --git a/pkgs/development/tools/build-managers/sbt/default.nix b/pkgs/development/tools/build-managers/sbt/default.nix
index 8db0cc0d54f3..9c23b85e2272 100644
--- a/pkgs/development/tools/build-managers/sbt/default.nix
+++ b/pkgs/development/tools/build-managers/sbt/default.nix
@@ -2,7 +2,7 @@
 
 stdenv.mkDerivation rec {
   name = "sbt-${version}";
-  version = "1.1.6";
+  version = "1.2.0";
 
   src = fetchurl {
     urls = [
@@ -10,7 +10,7 @@ stdenv.mkDerivation rec {
       "https://github.com/sbt/sbt/releases/download/v${version}/sbt-${version}.tgz"
       "https://cocl.us/sbt-${version}.tgz"
     ];
-    sha256 = "1hb8gcf3shcp4a65pnlqdlp8j5as7prqvw3d0b5bnfjfi0qbaigm";
+    sha256 = "1rrn0v4bhgar3mrgs931ifggb8kfg23fv5cgvskrdd7iyvg0z9wc";
   };
 
   patchPhase = ''
diff --git a/pkgs/development/tools/golangci-lint/default.nix b/pkgs/development/tools/golangci-lint/default.nix
new file mode 100644
index 000000000000..d2db1f1a2a69
--- /dev/null
+++ b/pkgs/development/tools/golangci-lint/default.nix
@@ -0,0 +1,24 @@
+{ buildGoPackage, fetchFromGitHub, lib }:
+
+buildGoPackage rec {
+  name = "golangci-lint-${version}";
+  version = "1.9.2";
+  goPackagePath = "github.com/golangci/golangci-lint";
+
+  subPackages = [ "cmd/golangci-lint" ];
+
+  src = fetchFromGitHub {
+    owner = "golangci";
+    repo = "golangci-lint";
+    rev = "v${version}";
+    sha256 = "0r05j6ayk5778fkd5r1sgcwq675ra0vq82lqs125g70291ryha08";
+  };
+
+  meta = with lib; {
+    description = "Linters Runner for Go. 5x faster than gometalinter. Nice colored output.";
+    homepage = https://golangci.com/;
+    license = licenses.agpl3;
+    platforms = platforms.unix;
+    maintainers = [ maintainers.manveru ];
+  };
+}
diff --git a/pkgs/development/tools/jq/default.nix b/pkgs/development/tools/jq/default.nix
index 6ee8c4074b78..93c465ce844a 100644
--- a/pkgs/development/tools/jq/default.nix
+++ b/pkgs/development/tools/jq/default.nix
@@ -34,12 +34,15 @@ stdenv.mkDerivation rec {
     "--datadir=\${doc}/share"
     "--mandir=\${man}/share/man"
     ]
-  # jq is linked to libjq:
+    # jq is linked to libjq:
     ++ stdenv.lib.optional (!stdenv.isDarwin) "LDFLAGS=-Wl,-rpath,\\\${libdir}";
 
-  installCheckPhase = "$bin/bin/jq --help >/dev/null";
   doInstallCheck = true;
-  doCheck = true;
+  installCheckTarget = "check";
+
+  postInstallCheck = ''
+    $bin/bin/jq --help >/dev/null
+  '';
 
   meta = with stdenv.lib; {
     description = ''A lightweight and flexible command-line JSON processor'';
diff --git a/pkgs/development/tools/skopeo/default.nix b/pkgs/development/tools/skopeo/default.nix
index 48f9822ad869..0e3a9706d24d 100644
--- a/pkgs/development/tools/skopeo/default.nix
+++ b/pkgs/development/tools/skopeo/default.nix
@@ -5,13 +5,13 @@
 with stdenv.lib;
 
 let
-  version = "0.1.30";
+  version = "0.1.31";
 
   src = fetchFromGitHub {
     rev = "v${version}";
     owner = "projectatomic";
     repo = "skopeo";
-    sha256 = "10lpiiki7mlhrp4bid40wys3lch7fars1whxsa5gy0frfgp89ghn";
+    sha256 = "02z46wxhms8yph03ksl7i4hbqy15v3y1r43js9dxn0a45vxkm7lb";
   };
 
   defaultPolicyFile = runCommand "skopeo-default-policy.json" {} "cp ${src}/default-policy.json $out";