summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMasayuki Takeda <mtakeda.enigsol@gmail.com>2018-03-07 19:09:32 +0900
committerMasayuki Takeda <mtakeda.enigsol@gmail.com>2018-03-07 19:09:32 +0900
commit3f738231177cb1823f912c7f566cffa94ae3440e (patch)
tree6b9f87826350c2b54d438e57dabab53bf74b5547 /pkgs/development
parent8154f9ebd50d1a3f94b8598b6868dad9ff6357d6 (diff)
downloadnixlib-3f738231177cb1823f912c7f566cffa94ae3440e.tar
nixlib-3f738231177cb1823f912c7f566cffa94ae3440e.tar.gz
nixlib-3f738231177cb1823f912c7f566cffa94ae3440e.tar.bz2
nixlib-3f738231177cb1823f912c7f566cffa94ae3440e.tar.lz
nixlib-3f738231177cb1823f912c7f566cffa94ae3440e.tar.xz
nixlib-3f738231177cb1823f912c7f566cffa94ae3440e.tar.zst
nixlib-3f738231177cb1823f912c7f566cffa94ae3440e.zip
camlimages: 4.1.2 -> 5.0.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/camlimages/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/camlimages/default.nix b/pkgs/development/ocaml-modules/camlimages/default.nix
new file mode 100644
index 000000000000..394b0c507be5
--- /dev/null
+++ b/pkgs/development/ocaml-modules/camlimages/default.nix
@@ -0,0 +1,12 @@
+{ stdenv, fetchzip, findlib, jbuilder, ocaml, configurator, cppo, lablgtk }:
+stdenv.mkDerivation rec {
+  name = "camlimages-${version}";
+  version = "5.0.0";
+  src = fetchzip {
+    url = "https://bitbucket.org/camlspotter/camlimages/get/${version}.tar.gz";
+    sha256 = "00qvwxkfnhv93yi1iq7vy3p5lxyi9xigxcq464s4ii6bmp32d998";
+  };
+  buildInputs = [ findlib jbuilder ocaml configurator cppo lablgtk ];
+  buildPhase = "jbuilder build -p camlimages";
+  inherit (jbuilder) installPhase;
+}