summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLancelot SIX <lsix+github@lancelotsix.com>2017-11-09 15:34:16 +0100
committerGitHub <noreply@github.com>2017-11-09 15:34:16 +0100
commit3d8be08cf8078d8f1b82316876c072e2a997aa03 (patch)
tree20016b207440db808b1866f3e665b397a42fa8df /pkgs/development
parentb306298bdcf87f354025b2272c0eee3facae43cf (diff)
parente4c7cfc9eb851a5ed92644c5e93837d186cb9edc (diff)
downloadnixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.tar
nixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.tar.gz
nixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.tar.bz2
nixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.tar.lz
nixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.tar.xz
nixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.tar.zst
nixlib-3d8be08cf8078d8f1b82316876c072e2a997aa03.zip
Merge pull request #31394 from xvapx/sybase
pythonPackages.sybase: move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/sybase/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/sybase/default.nix b/pkgs/development/python-modules/sybase/default.nix
new file mode 100644
index 000000000000..df27172d8d49
--- /dev/null
+++ b/pkgs/development/python-modules/sybase/default.nix
@@ -0,0 +1,30 @@
+{ stdenv
+, buildPythonPackage
+, fetchurl
+, isPy3k
+, freetds
+}:
+
+buildPythonPackage rec {
+  name = "python-sybase-${version}";
+  version = "0.40pre2";
+  disabled = isPy3k;
+
+  src = fetchurl {
+    url = "https://sourceforge.net/projects/python-sybase/files/python-sybase/${name}/${name}.tar.gz";
+    sha256 = "0pm88hyn18dy7ljam4mdx9qqgmgraf2zy2wl02g5vsjl4ncvq90j";
+  };
+
+  propagatedBuildInputs = [ freetds ];
+
+  SYBASE = freetds;
+  setupPyBuildFlags = [ "-DHAVE_FREETDS" "-UWANT_BULKCOPY" ];
+
+  meta = with stdenv.lib; {
+    description = "The Sybase module provides a Python interface to the Sybase relational database system";
+    homepage    = http://python-sybase.sourceforge.net;
+    license     = licenses.bsd3;
+    maintainers = with maintainers; [ veprbl ];
+    platforms   = platforms.unix;
+  };
+}