summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-13 17:39:54 -0400
committerMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 02:34:32 -0400
commit3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf (patch)
tree0ad7d05a1d1b0249b8a40c9be77429d518a9d335 /pkgs/development
parent1781e955779397e4c39d406909823841210df962 (diff)
downloadnixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.tar
nixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.tar.gz
nixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.tar.bz2
nixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.tar.lz
nixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.tar.xz
nixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.tar.zst
nixlib-3c5e31ec00a02a35a9ec1f377a9bbbb181745ddf.zip
js_build_tools: init at 113.33.06
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/janestreet/js-build-tools.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix b/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix
new file mode 100644
index 000000000000..d6e67b277cac
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix
@@ -0,0 +1,27 @@
+{stdenv, buildOcaml, fetchurl, ocaml_oasis, opam}:
+
+buildOcaml rec {
+  name = "js-build-tools";
+  version = "113.33.06";
+
+  minimumSupportedOcamlVersion = "4.02";
+
+  src = fetchurl {
+    url = "https://github.com/janestreet/${name}/archive/${version}.tar.gz";
+    sha256 = "1nvgyp4gsnlnpix3li6kr90b12iin5ihichv298p03i6h2809dia";
+  };
+
+  hasSharedObjects = true;
+
+  buildInputs = [ ocaml_oasis opam ];
+
+  dontAddPrefix = true;
+  configurePhase = "./configure --prefix $prefix";
+  installPhase = "opam-installer -i --prefix $prefix --libdir `ocamlfind printconf destdir` ${name}.install";
+
+  meta = with stdenv.lib; {
+    description = "Jane Street Build Tools";
+    maintainers = [ maintainers.maurer ];
+    license = licenses.asl20;
+  };
+}