summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-07-09 16:33:48 +0200
committerVladimír Čunát <vcunat@gmail.com>2016-07-09 16:36:49 +0200
commit3b2627586d4ce20e2a8e7b47dbcce5d72e45673a (patch)
tree458124b83cd6d7245b86e29e1a6e9af5b00537ee /pkgs/development
parent0cdf89276952e00083846dd85c7cc6291861f986 (diff)
parent586a9c0d9ced543c5d2f958792b5f7adcdc1792b (diff)
downloadnixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.tar
nixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.tar.gz
nixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.tar.bz2
nixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.tar.lz
nixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.tar.xz
nixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.tar.zst
nixlib-3b2627586d4ce20e2a8e7b47dbcce5d72e45673a.zip
Merge #16448: gnumake: optionally build with guile
Fixed up nested lists within the merge.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/gnumake/4.2/default.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/pkgs/development/tools/build-managers/gnumake/4.2/default.nix b/pkgs/development/tools/build-managers/gnumake/4.2/default.nix
index a3c8327655ee..edb3f841069a 100644
--- a/pkgs/development/tools/build-managers/gnumake/4.2/default.nix
+++ b/pkgs/development/tools/build-managers/gnumake/4.2/default.nix
@@ -1,4 +1,6 @@
-{ stdenv, fetchurl }:
+{ stdenv, fetchurl, guileSupport ? false, pkgconfig ? null , guile ? null }:
+
+assert guileSupport -> ( pkgconfig != null && guile != null );
 
 let
   version = "4.2";
@@ -19,12 +21,16 @@ stdenv.mkDerivation {
     ./impure-dirs.patch
   ];
 
+  buildInputs = stdenv.lib.optionals guileSupport [ guile pkgconfig ];
+
+  configureFlags = stdenv.lib.optional guileSupport "--with-guile";
+
   outputs = [ "out" "doc" ];
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.gnu.org/software/make/;
     description = "A tool to control the generation of non-source files from sources";
-    license = stdenv.lib.licenses.gpl3Plus;
+    license = licenses.gpl3Plus;
 
     longDescription = ''
       Make is a tool which controls the generation of executables and
@@ -37,6 +43,7 @@ stdenv.mkDerivation {
       to build and install the program.
     '';
 
-    platforms = stdenv.lib.platforms.all;
+    platforms = platforms.all;
+    maintainers = [ maintainers.vrthra ];
   };
 }