summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2018-08-26 15:15:27 +0300
committerJaakko Luttinen <jaakko.luttinen@iki.fi>2018-09-12 08:44:19 +0300
commit38e86a8f1e7d58ba494a83242ccd580e890741a6 (patch)
tree3b6aff7088c73c973a5fc5f334d955180cfa2f63 /pkgs/development
parentf053daf36ceb956e19a78115e4abdf46058fec25 (diff)
downloadnixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.tar
nixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.tar.gz
nixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.tar.bz2
nixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.tar.lz
nixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.tar.xz
nixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.tar.zst
nixlib-38e86a8f1e7d58ba494a83242ccd580e890741a6.zip
pythonPackages.python-u2flib-host: init at 3.0.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/python-u2flib-host/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/python-u2flib-host/default.nix b/pkgs/development/python-modules/python-u2flib-host/default.nix
new file mode 100644
index 000000000000..38785d813138
--- /dev/null
+++ b/pkgs/development/python-modules/python-u2flib-host/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchPypi, buildPythonPackage, requests, hidapi }:
+
+buildPythonPackage rec {
+  pname = "python-u2flib-host";
+  version = "3.0.3";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "02pwafd5kyjpc310ys0pgnd0adff1laz18naxxwsfrllqafqnrxb";
+  };
+
+  propagatedBuildInputs = [ requests hidapi ];
+
+  # Tests fail: "ValueError: underlying buffer has been detached"
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    description = "Python based U2F host library";
+    homepage = https://github.com/Yubico/python-u2flib-host;
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ jluttine ];
+  };
+}