summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@users.noreply.github.com>2016-07-07 23:51:44 +0200
committerGitHub <noreply@github.com>2016-07-07 23:51:44 +0200
commit386d4821b4d4b6c432322c203c1cf8fc18549750 (patch)
treefd01cab6bd11e8e02dbb56ade43af93bc543d819 /pkgs/development
parenta2ebf45b4708d6103c77734e04d9067e57ea5cd5 (diff)
parent401016780339eb62f51c294f51d02dc363199dd5 (diff)
downloadnixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.tar
nixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.tar.gz
nixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.tar.bz2
nixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.tar.lz
nixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.tar.xz
nixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.tar.zst
nixlib-386d4821b4d4b6c432322c203c1cf8fc18549750.zip
Merge pull request #16765 from rasendubi/io
io: clean up
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/io/default.nix30
1 files changed, 15 insertions, 15 deletions
diff --git a/pkgs/development/interpreters/io/default.nix b/pkgs/development/interpreters/io/default.nix
index 8ed50b886876..5adca2c0b42c 100644
--- a/pkgs/development/interpreters/io/default.nix
+++ b/pkgs/development/interpreters/io/default.nix
@@ -13,28 +13,25 @@ stdenv.mkDerivation {
     sha256 = "0ll2kd72zy8vf29sy0nnx3awk7nywpwpv21rvninjjaqkygrc0qw";
   };
 
+  nativeBuildInputs = [
+    cmake
+  ];
+
   buildInputs = [
-    cmake zlib sqlite gmp libffi cairo ncurses freetype
+    zlib sqlite gmp libffi cairo ncurses freetype
     mesa libpng libtiff libjpeg readline libsndfile libxml2
     freeglut libsamplerate pcre libevent libedit yajl
     pkgconfig glfw openssl libpthreadstubs libXdmcp
     libmemcached python3
   ];
 
-  configurePhase=''
-  # The Addon generation (AsyncRequest and a others checked) seems to have
-  # trouble with building on Virtual machines. Disabling them until it
-  # can be fully investigated.
-  sed -ie \
-        "s/add_subdirectory(addons)/#add_subdirectory(addons)/g" \
-        CMakeLists.txt
-  mkdir build
-  cd build
-  cmake  -DCMAKE_INSTALL_PREFIX="$out" ..
-  '';
-
-  installPhase=''
-  make install
+  preConfigure = ''
+    # The Addon generation (AsyncRequest and a others checked) seems to have
+    # trouble with building on Virtual machines. Disabling them until it
+    # can be fully investigated.
+    sed -ie \
+          "s/add_subdirectory(addons)/#add_subdirectory(addons)/g" \
+          CMakeLists.txt
   '';
 
   # for gcc5; c11 inline semantics breaks the build
@@ -42,6 +39,9 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     description = "Io programming language";
+    homepage = http://iolanguage.org/;
+    license = licenses.bsd3;
+
     maintainers = with maintainers; [
       raskin
       z77z