summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorobadz <obadz-git@obadz.com>2018-05-01 23:33:06 +0100
committerRobin Gloster <mail@glob.in>2018-05-03 02:17:13 +0200
commit380c91ddfb58aef60d06d6b3c481eb0ad4c4a532 (patch)
treeaa702074259d7889db27ea320e522c123c6244e8 /pkgs/development
parent51c13292bd413614a981fb4381ac8063baed14ec (diff)
downloadnixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.tar
nixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.tar.gz
nixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.tar.bz2
nixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.tar.lz
nixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.tar.xz
nixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.tar.zst
nixlib-380c91ddfb58aef60d06d6b3c481eb0ad4c4a532.zip
libtorrent-rasterbar: 1.1.6 -> 1.1.7
Also remove the default/generic split as it seems there's only one
version anyway.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libtorrent-rasterbar/default.nix41
-rw-r--r--pkgs/development/libraries/libtorrent-rasterbar/generic.nix43
2 files changed, 36 insertions, 48 deletions
diff --git a/pkgs/development/libraries/libtorrent-rasterbar/default.nix b/pkgs/development/libraries/libtorrent-rasterbar/default.nix
index 00ec22986179..e3b8024615be 100644
--- a/pkgs/development/libraries/libtorrent-rasterbar/default.nix
+++ b/pkgs/development/libraries/libtorrent-rasterbar/default.nix
@@ -1,6 +1,37 @@
-args@{ callPackage, ... }:
+{ stdenv, fetchurl, automake, autoconf, boost, openssl, lib, libtool, pkgconfig, zlib, python, libiconv, geoip, ... }:
 
-callPackage (import ./generic.nix {
-  version = "1.1.6";
-  sha256 = "1xlh0sqypjbx0imw3bkbjwgwb4bm6zl7c0y01p0xsw8ncfmwjll7";
-}) args
+stdenv.mkDerivation rec {
+  name = "libtorrent-rasterbar-${version}";
+  version = "1.1.7";
+
+  src =
+    let formattedVersion = lib.replaceChars ["."] ["_"] version;
+    in fetchurl {
+      url = "https://github.com/arvidn/libtorrent/archive/libtorrent-${formattedVersion}.tar.gz";
+      sha256 = "0vbw7wcw8x9787rq5fwaibpvvspm3237l8ahbf20gjpzxhn4yfwc";
+    };
+
+  nativeBuildInputs = [ automake autoconf libtool pkgconfig ];
+  buildInputs = [ boost openssl zlib python libiconv geoip ];
+
+  preConfigure = "./autotool.sh";
+
+  configureFlags = [
+    "--enable-python-binding"
+    "--with-libgeoip=system"
+    "--with-libiconv=yes"
+    "--with-boost=${boost.dev}"
+    "--with-boost-libdir=${boost.out}/lib"
+    "--with-libiconv=yes"
+  ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    homepage = http://www.rasterbar.com/products/libtorrent/;
+    description = "A C++ BitTorrent implementation focusing on efficiency and scalability";
+    license = licenses.bsd3;
+    maintainers = [ maintainers.phreedom ];
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/development/libraries/libtorrent-rasterbar/generic.nix b/pkgs/development/libraries/libtorrent-rasterbar/generic.nix
deleted file mode 100644
index 8c85864f87a5..000000000000
--- a/pkgs/development/libraries/libtorrent-rasterbar/generic.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-# Version specific options
-{ version, sha256, patches ? [] }:
-
-{ stdenv, fetchurl, automake, autoconf, boost, openssl, lib, libtool, pkgconfig, zlib, python, libiconv, geoip, ... }:
-
-let formattedVersion = lib.replaceChars ["."] ["_"] version;
-
-in
-
-stdenv.mkDerivation rec {
-  name = "libtorrent-rasterbar-${version}";
-
-  src = fetchurl {
-    url = "https://github.com/arvidn/libtorrent/archive/libtorrent-${formattedVersion}.tar.gz";
-    inherit sha256;
-  };
-
-  inherit patches;
-
-  nativeBuildInputs = [ automake autoconf libtool pkgconfig ];
-  buildInputs = [ boost openssl zlib python libiconv geoip ];
-
-  preConfigure = "./autotool.sh";
-
-  configureFlags = [ 
-    "--enable-python-binding"
-    "--with-libgeoip=system"
-    "--with-libiconv=yes"
-    "--with-boost=${boost.dev}"
-    "--with-boost-libdir=${boost.out}/lib"
-    "--with-libiconv=yes"
-  ];
-
-  enableParallelBuilding = true;
-
-  meta = with stdenv.lib; {
-    homepage = http://www.rasterbar.com/products/libtorrent/;
-    description = "A C++ BitTorrent implementation focusing on efficiency and scalability";
-    license = licenses.bsd3;
-    maintainers = [ maintainers.phreedom ];
-    platforms = platforms.unix;
-  };
-}