summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSamuel Rivas <samuelrivas@gmail.com>2015-07-28 17:31:44 +0200
committerSamuel Rivas <samuel.rivas@klarna.com>2015-08-06 08:06:51 +0200
commit37d0d8ac7411af01761dbaf58bfa7d673453af2a (patch)
tree24cdb59fcef981934a3b783cef0501c9993416e1 /pkgs/development
parentd516f12dbae4fccf184cef11ce49529b56e9df39 (diff)
downloadnixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.tar
nixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.tar.gz
nixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.tar.bz2
nixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.tar.lz
nixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.tar.xz
nixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.tar.zst
nixlib-37d0d8ac7411af01761dbaf58bfa7d673453af2a.zip
utop: 1.15 -> 1.17
Version 1.18 doesn't compile cleanly currently, I need to debug what is going on
there
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/ocaml/utop/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/pkgs/development/tools/ocaml/utop/default.nix b/pkgs/development/tools/ocaml/utop/default.nix
index c5c0ac9a3ed8..c9addf55312c 100644
--- a/pkgs/development/tools/ocaml/utop/default.nix
+++ b/pkgs/development/tools/ocaml/utop/default.nix
@@ -1,22 +1,24 @@
 {stdenv, fetchurl, ocaml, findlib, lambdaTerm, ocaml_lwt, makeWrapper,
- ocaml_react, camomile, zed
+ ocaml_react, camomile, zed, cppo, camlp4
 }:
 
 stdenv.mkDerivation rec {
-  version = "1.15";
+  version = "1.17";
   name = "utop-${version}";
 
   src = fetchurl {
-    url = https://github.com/diml/utop/archive/1.15.tar.gz;
-    sha256 = "106v0x6sa2x10zgmjf73mpzws7xiqanxswivd00iqnpc0bcpkmrr";
+    url = "https://github.com/diml/utop/archive/${version}.tar.gz";
+    sha256 = "0l9lz2nypl2ls3kqzmp738m02yvscabhsfpj70ckp0p98pimnnfd";
   };
 
-  buildInputs = [ ocaml findlib makeWrapper];
+  buildInputs = [ ocaml findlib makeWrapper cppo camlp4 ];
 
   propagatedBuildInputs = [ lambdaTerm ocaml_lwt ];
 
   createFindlibDestdir = true;
 
+  configureFlags = "--enable-camlp4";
+
   buildPhase = ''
     make
     make doc