summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2014-05-23 16:54:46 +0200
committerPeter Simons <simons@cryp.to>2014-05-23 17:39:15 +0200
commit34c6a26f5dda453b5a332a0b13564dd4c13069c5 (patch)
tree1297be19985748b4b47added00c82b77e24abb2c /pkgs/development
parentd7bc0de8c851cfd2a228813060d2780ce3e63b2c (diff)
downloadnixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.tar
nixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.tar.gz
nixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.tar.bz2
nixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.tar.lz
nixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.tar.xz
nixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.tar.zst
nixlib-34c6a26f5dda453b5a332a0b13564dd4c13069c5.zip
haskell-compdata: add version 0.7.0.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/haskell/compdata/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/libraries/haskell/compdata/default.nix b/pkgs/development/libraries/haskell/compdata/default.nix
new file mode 100644
index 000000000000..564f1179d875
--- /dev/null
+++ b/pkgs/development/libraries/haskell/compdata/default.nix
@@ -0,0 +1,23 @@
+{ cabal, deepseq, derive, HUnit, mtl, QuickCheck, testFramework
+, testFrameworkHunit, testFrameworkQuickcheck2, thExpandSyns
+, transformers
+}:
+
+cabal.mkDerivation (self: {
+  pname = "compdata";
+  version = "0.7.0.1";
+  sha256 = "0d511yjfydv43sr74ggz6pnqm0wqz2m9fgrxpl6avvj8p10va7h7";
+  buildDepends = [
+    deepseq derive mtl QuickCheck thExpandSyns transformers
+  ];
+  testDepends = [
+    deepseq derive HUnit mtl QuickCheck testFramework
+    testFrameworkHunit testFrameworkQuickcheck2 thExpandSyns
+    transformers
+  ];
+  meta = {
+    description = "Compositional Data Types";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+  };
+})