summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTadas Barzdzius <tadas@barzdzius.lt>2016-12-29 09:56:19 +0200
committerTadas Barzdzius <tadas@barzdzius.lt>2016-12-29 09:56:19 +0200
commit31ec0795f6bcad548ae6b73097ce1d045400bd78 (patch)
tree42c0100b719978559e3decb9718bb885ea629c3f /pkgs/development
parent7fa4b0f2c94156dfcb177ed8fbadc8c8d1162dad (diff)
downloadnixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.tar
nixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.tar.gz
nixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.tar.bz2
nixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.tar.lz
nixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.tar.xz
nixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.tar.zst
nixlib-31ec0795f6bcad548ae6b73097ce1d045400bd78.zip
cargo: 0.14 -> 0.15
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/rust/cargo.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/development/compilers/rust/cargo.nix b/pkgs/development/compilers/rust/cargo.nix
index 537764ebca2b..2b544d754d79 100644
--- a/pkgs/development/compilers/rust/cargo.nix
+++ b/pkgs/development/compilers/rust/cargo.nix
@@ -24,7 +24,7 @@ rustPlatform.buildRustPackage rec {
   LIBGIT2_SYS_USE_PKG_CONFIG=1;
 
   configurePhase = ''
-    ./configure --enable-optimize --prefix=$out --local-cargo=${rustPlatform.rust.cargo}/bin/cargo
+    ./configure --enable-optimize --prefix=$out
   '';
 
   buildPhase = "make";
@@ -60,7 +60,7 @@ rustPlatform.buildRustPackage rec {
     cargo test
   '';
 
-  # Disable check phase as there are failures (author_prefers_cargo test fails)
+  # Disable check phase as there are failures (4 tests fail)
   doCheck = false;
 
   meta = with stdenv.lib; {