summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-13 21:37:22 -0400
committerMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 02:36:07 -0400
commit3062264c3acb5aa69f4595bbcb507bc765112320 (patch)
tree8888be5d9cfc0fb2937f0b1a7748fa57a152e6c1 /pkgs/development
parent0561329ae514a4bd4ed06cf787c28817ace3e892 (diff)
downloadnixlib-3062264c3acb5aa69f4595bbcb507bc765112320.tar
nixlib-3062264c3acb5aa69f4595bbcb507bc765112320.tar.gz
nixlib-3062264c3acb5aa69f4595bbcb507bc765112320.tar.bz2
nixlib-3062264c3acb5aa69f4595bbcb507bc765112320.tar.lz
nixlib-3062264c3acb5aa69f4595bbcb507bc765112320.tar.xz
nixlib-3062264c3acb5aa69f4595bbcb507bc765112320.tar.zst
nixlib-3062264c3acb5aa69f4595bbcb507bc765112320.zip
ocaml-re2: 112.06.00 -> 112.06.00/113.33.03
PPX/P4 split
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/core_extended/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/janestreet/re2.nix20
2 files changed, 22 insertions, 2 deletions
diff --git a/pkgs/development/ocaml-modules/core_extended/default.nix b/pkgs/development/ocaml-modules/core_extended/default.nix
index e53c46894482..d25cd81bcd8a 100644
--- a/pkgs/development/ocaml-modules/core_extended/default.nix
+++ b/pkgs/development/ocaml-modules/core_extended/default.nix
@@ -1,5 +1,5 @@
 {stdenv, buildOcaml, fetchurl, bin_prot_p4, comparelib, core_p4, custom_printf,
- fieldslib_p4, pa_bench, pa_ounit, pipebang, pa_test, textutils, re2, sexplib_p4}:
+ fieldslib_p4, pa_bench, pa_ounit, pipebang, pa_test, textutils, re2_p4, sexplib_p4}:
 
 buildOcaml rec {
   name = "core_extended";
@@ -15,7 +15,7 @@ buildOcaml rec {
   hasSharedObjects = true;
   buildInputs = [ pa_bench pa_test pa_ounit ];
   propagatedBuildInputs = [bin_prot_p4 comparelib core_p4 custom_printf fieldslib_p4
-                           pipebang textutils re2 sexplib_p4 ];
+                           pipebang textutils re2_p4 sexplib_p4 ];
 
   meta = with stdenv.lib; {
     homepage = https://github.com/janestreet/core_extended;
diff --git a/pkgs/development/ocaml-modules/janestreet/re2.nix b/pkgs/development/ocaml-modules/janestreet/re2.nix
new file mode 100644
index 000000000000..6604a8d012c6
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/re2.nix
@@ -0,0 +1,20 @@
+{stdenv, buildOcamlJane,
+ bin_prot, core_kernel, fieldslib, sexplib, typerep, variantslib,
+ ppx_assert, ppx_bench, ppx_driver, ppx_expect, ppx_inline_test, ppx_jane,
+ rsync}:
+
+buildOcamlJane rec {
+  name = "re2";
+  hash = "0fw5jscb1i17aw8v4l965zw20kyimhfnmf4w83wqaaxkqy3l6fqw";
+  buildInputs = [ rsync ];
+  propagatedBuildInputs =
+    [ bin_prot core_kernel fieldslib sexplib typerep variantslib
+      ppx_assert ppx_bench ppx_driver ppx_expect ppx_inline_test ppx_jane ];
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/janestreet/re2;
+    description = "OCaml bindings for RE2";
+    maintainers = [ maintainers.maurer ];
+    license = licenses.asl20;
+  };
+}