summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorlethalman <lucabru@src.gnome.org>2015-12-07 10:50:39 +0100
committerlethalman <lucabru@src.gnome.org>2015-12-07 10:50:39 +0100
commit2fde83b5bde2c5d360610c38e32558967aa6a7b8 (patch)
tree617e4f37483e13aa56d35ef1c1514a0c0dfafbf6 /pkgs/development
parent6d13f373f41a4fdd24de441d8eb196ba02db729a (diff)
parent2c54da93ef727b366433d112e78b4d4a1bd2fb6d (diff)
downloadnixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.tar
nixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.tar.gz
nixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.tar.bz2
nixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.tar.lz
nixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.tar.xz
nixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.tar.zst
nixlib-2fde83b5bde2c5d360610c38e32558967aa6a7b8.zip
Merge pull request #11411 from hrdinka/mapnik
mapnik: init at 3.0.9
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/mapnik/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/development/libraries/mapnik/default.nix b/pkgs/development/libraries/mapnik/default.nix
new file mode 100644
index 000000000000..4f0311f9d92b
--- /dev/null
+++ b/pkgs/development/libraries/mapnik/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl
+, boost, cairo, freetype, gdal, harfbuzz, icu, libjpeg, libpng, libtiff
+, libwebp, libxml2, proj, python, scons, sqlite, zlib
+}:
+
+stdenv.mkDerivation rec {
+  name = "mapnik-${version}";
+  version = "3.0.9";
+
+  src = fetchurl {
+    url = "https://mapnik.s3.amazonaws.com/dist/v${version}/mapnik-v${version}.tar.bz2";
+    sha256 = "1nnkamwq4vcg4q2lbqn7cn8sannxszzjxcxsllksby055d9nfgrs";
+  };
+
+  nativeBuildInputs = [ python scons ];
+
+  buildInputs =
+    [ boost cairo freetype gdal harfbuzz icu libjpeg libpng libtiff
+      libwebp libxml2 proj python sqlite zlib
+    ];
+
+  configurePhase = ''
+    scons configure PREFIX="$out"
+  '';
+
+  buildPhase = false;
+
+  installPhase = ''
+    mkdir -p "$out"
+    scons install
+  '';
+
+  meta = with stdenv.lib; {
+    description = "An open source toolkit for developing mapping applications";
+    homepage = http://mapnik.org;
+    maintainers = with maintainers; [ hrdinka ];
+    license = licenses.lgpl21;
+    platforms = platforms.all;
+  };
+}