summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-25 14:21:52 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-05-25 14:52:58 -0400
commit2e70a75b12eb6a092557852a22ab3cb05cfa4006 (patch)
tree1ce6536bac8e760e9b276e2f50f5a9b6aa324f58 /pkgs/development
parentce0180dfd56cc00223daa5ad99d4b5611f09c542 (diff)
downloadnixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.tar
nixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.tar.gz
nixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.tar.bz2
nixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.tar.lz
nixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.tar.xz
nixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.tar.zst
nixlib-2e70a75b12eb6a092557852a22ab3cb05cfa4006.zip
haskell generic-builder: Limit usage of --extra-framework-dirs for compat
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/generic-builder.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/generic-builder.nix b/pkgs/development/haskell-modules/generic-builder.nix
index 8d9b596276c3..1a39fa6b2338 100644
--- a/pkgs/development/haskell-modules/generic-builder.nix
+++ b/pkgs/development/haskell-modules/generic-builder.nix
@@ -212,6 +212,9 @@ let
     if [ -d "$p/lib" ]; then
       configureFlags+=" --extra-lib-dirs=$p/lib"
     fi
+  ''
+  # It is not clear why --extra-framework-dirs does work fine on Linux
+  + optionalString (!buildPlatform.isDarwin || versionAtLeast nativeGhc.version "8.0") ''
     if [[ -d "$p/Library/Frameworks" ]]; then
       configureFlags+=" --extra-framework-dirs=$p/Library/Frameworks"
     fi