summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2012-05-31 11:04:28 +0000
committerMichael Raskin <7c6f434c@mail.ru>2012-05-31 11:04:28 +0000
commit2de23edd59572ae8f10b11d7d3c516ac3eae7944 (patch)
tree965e0408cf16aa68c86c6e2a5073ef78fab94c92 /pkgs/development
parent83d7540add197fc466257cb3c0370c3874b5d614 (diff)
downloadnixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.tar
nixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.tar.gz
nixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.tar.bz2
nixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.tar.lz
nixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.tar.xz
nixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.tar.zst
nixlib-2de23edd59572ae8f10b11d7d3c516ac3eae7944.zip
Adding LLVM 3.1. (as a separate attribute, because it seems to be API-incompatible)
svn path=/nixpkgs/trunk/; revision=34300
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/llvm/3.1.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/development/compilers/llvm/3.1.nix b/pkgs/development/compilers/llvm/3.1.nix
new file mode 100644
index 000000000000..d0c7e6891138
--- /dev/null
+++ b/pkgs/development/compilers/llvm/3.1.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl, perl, groff, cmake, python }:
+
+let version = "3.1"; in
+
+stdenv.mkDerivation {
+  name = "llvm-${version}";
+
+  src = fetchurl {
+    url    = "http://llvm.org/releases/${version}/llvm-${version}.src.tar.gz";
+    sha256 = "1ea05135197b5400c1f88d00ff280d775ce778f8f9ea042e25a1e1e734a4b9ab";
+  };
+
+  buildInputs = [ perl groff cmake python ];
+
+  cmakeFlags = [ "-DCMAKE_BUILD_TYPE=Release" ];
+
+  enableParallelBuilding = true;
+
+  meta = {
+    homepage = http://llvm.org/;
+    description = "Collection of modular and reusable compiler and toolchain technologies";
+    license = "BSD";
+    maintainers = with stdenv.lib.maintainers; [viric shlevy];
+    platforms = with stdenv.lib.platforms; all;
+  };
+}
+