summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2017-05-26 19:53:52 +0200
committerPeter Simons <simons@cryp.to>2017-05-27 10:32:49 +0200
commit2c2965c3957f28f06c5312b9ef5875913a367c5e (patch)
treeb60f3f1505a73b124b0b7873580e056911ca6032 /pkgs/development
parentbf09054ff07363332d4193940a5bd3969d91a4b3 (diff)
downloadnixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.tar
nixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.tar.gz
nixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.tar.bz2
nixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.tar.lz
nixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.tar.xz
nixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.tar.zst
nixlib-2c2965c3957f28f06c5312b9ef5875913a367c5e.zip
liquid-fixpoint: disable shared executables to fix the test suite
The test suite runs "fixpoint" in an environment where the required library
search paths aren't set up properly.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index 6bdfe99cfeea..c954f06518bc 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -198,9 +198,6 @@ self: super: builtins.intersectAttrs super {
   # Nix-specific workaround
   xmonad = appendPatch (dontCheck super.xmonad) ./patches/xmonad-nix.patch;
 
-  # https://github.com/ucsd-progsys/liquid-fixpoint/issues/44
-  # liquid-fixpoint = overrideCabal super.liquid-fixpoint (drv: { preConfigure = "patchShebangs ."; });
-
   # wxc supports wxGTX >= 3.0, but our current default version points to 2.8.
   # http://hydra.cryp.to/build/1331287/log/raw
   wxc = (addBuildDepend super.wxc self.split).override { wxGTK = pkgs.wxGTK30; };
@@ -458,4 +455,9 @@ self: super: builtins.intersectAttrs super {
   # loc and loc-test depend on each other for testing. Break that infinite cycle:
   loc-test = super.loc-test.override { loc = dontCheck self.loc; };
 
+  # The test suite tries to run the "fixpoint" executable just built before and
+  # fails, probably because the library search paths don't add up and it can't
+  # find its own shared library.
+  liquid-fixpoint = disableSharedExecutables super.liquid-fixpoint;
+
 }