summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-03-01 12:03:48 +0100
committerRobin Gloster <mail@glob.in>2018-03-01 14:43:12 +0100
commit2937f81e61b9ae170ad1647d417553603391401e (patch)
tree600988293ff52f80d3240dfd7173525a809bd367 /pkgs/development
parent5f5c41dadcbfe1655448c2000a72e86fdc721250 (diff)
downloadnixlib-2937f81e61b9ae170ad1647d417553603391401e.tar
nixlib-2937f81e61b9ae170ad1647d417553603391401e.tar.gz
nixlib-2937f81e61b9ae170ad1647d417553603391401e.tar.bz2
nixlib-2937f81e61b9ae170ad1647d417553603391401e.tar.lz
nixlib-2937f81e61b9ae170ad1647d417553603391401e.tar.xz
nixlib-2937f81e61b9ae170ad1647d417553603391401e.tar.zst
nixlib-2937f81e61b9ae170ad1647d417553603391401e.zip
pythonPackages.pylama: init at 7.4.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pylama/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/pylama/default.nix b/pkgs/development/python-modules/pylama/default.nix
new file mode 100644
index 000000000000..c4ef98b43ef6
--- /dev/null
+++ b/pkgs/development/python-modules/pylama/default.nix
@@ -0,0 +1,33 @@
+{ lib, buildPythonPackage, fetchPypi, fetchpatch
+, mccabe, pycodestyle, pydocstyle, pyflakes
+, pytest, ipdb }:
+
+buildPythonPackage rec {
+  pname = "pylama";
+  version = "7.4.3";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "390c1dab1daebdf3d6acc923e551b035c3faa77d8b96b98530c230493f9ec712";
+  };
+
+  patches = fetchpatch {
+    url = "${meta.homepage}/pull/116.patch";
+    sha256 = "00jz5k2w0xahs1m3s603j6l4cwzz92qsbbk81fh17nq0f47999mv";
+  };
+
+  propagatedBuildInputs = [ mccabe pycodestyle pydocstyle pyflakes ];
+
+  checkInputs = [ pytest ipdb ];
+
+  # tries to mess with the file system
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Code audit tool for python";
+    homepage = https://github.com/klen/pylama;
+    # ambiguous license declarations: https://github.com/klen/pylama/issues/64
+    license = licenses.lgpl3;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}