summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-09-21 17:01:52 +0000
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-09-21 17:04:23 +0000
commit26aa4c36baa119cb108b9949190eb170a16c9ff6 (patch)
treeabaa5fd7ffcb58b98b2804a35cbb4558a9687039 /pkgs/development
parentab2f86aec3c5d9bc97041a47b76bfe757a33e19a (diff)
downloadnixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.tar
nixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.tar.gz
nixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.tar.bz2
nixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.tar.lz
nixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.tar.xz
nixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.tar.zst
nixlib-26aa4c36baa119cb108b9949190eb170a16c9ff6.zip
ocamlPackages.erm_xmpp: 0.3 -> 0.3+20180112
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/erm_xmpp/0.3.nix29
-rw-r--r--pkgs/development/ocaml-modules/erm_xmpp/default.nix41
2 files changed, 20 insertions, 50 deletions
diff --git a/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix b/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix
deleted file mode 100644
index 1a8f854185a2..000000000000
--- a/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ stdenv, buildOcaml, fetchFromGitHub, ocaml, findlib, erm_xml, nocrypto }:
-
-buildOcaml rec {
-  version = "0.3";
-  name = "erm_xmpp";
-
-  src = fetchFromGitHub {
-    owner  = "hannesm";
-    repo   = "xmpp";
-    rev    = "eee18bd3dd343550169969c0b45548eafd51cfe1";
-    sha256 = "0hzs528lrx1ayalv6fh555pjn0b4l8xch1f72hd3b07g1xahdas5";
-  };
-
-  buildInputs = [ ocaml findlib ];
-  propagatedBuildInputs = [ erm_xml nocrypto ];
-
-  configurePhase = "ocaml setup.ml -configure --prefix $out";
-  buildPhase = "ocaml setup.ml -build";
-  installPhase = "ocaml setup.ml -install";
-
-  createFindlibDestdir = true;
-
-  meta = {
-    homepage = https://github.com/hannesm/xmpp;
-    description = "OCaml based XMPP implementation (fork)";
-    license = stdenv.lib.licenses.bsd3;
-    maintainers = with stdenv.lib.maintainers; [ sternenseemann ];
-  };
-}
diff --git a/pkgs/development/ocaml-modules/erm_xmpp/default.nix b/pkgs/development/ocaml-modules/erm_xmpp/default.nix
index c6027ce11ce5..a6bb75e61c24 100644
--- a/pkgs/development/ocaml-modules/erm_xmpp/default.nix
+++ b/pkgs/development/ocaml-modules/erm_xmpp/default.nix
@@ -1,33 +1,32 @@
-{ stdenv, fetchurl, fetchzip, ocaml, findlib, ocamlbuild, erm_xml, cryptokit, camlp4 }:
+{ stdenv, fetchFromGitHub, ocaml, findlib, camlp4, ocamlbuild
+, erm_xml, nocrypto
+}:
 
-let
-  version = "0.2";
-  disable-tests = fetchurl {
-    url = https://raw.githubusercontent.com/ocaml/opam-repository/master/packages/erm_xmpp/erm_xmpp.0.2/files/disable_tests.patch;
-    sha256 = "09d8630nmx2x8kb8ap1zmsb93zs14cqg7ga1gmdl92jvsjxbhgc1";
-  };
-in
-
-stdenv.mkDerivation {
-  name = "ocaml-erm_xmpp-${version}";
+stdenv.mkDerivation rec {
+  version = "0.3+20180112";
+  name = "ocaml${ocaml.version}-erm_xmpp-${version}";
 
-  src = fetchzip {
-    url = "https://github.com/ermine/xmpp/archive/v${version}.tar.gz";
-    sha256 = "0saw2dmrzv2aadrznvyvchnhivvcwm78x9nwf6flq5v0pqddapk2";
+  src = fetchFromGitHub {
+    owner  = "hannesm";
+    repo   = "xmpp";
+    rev    = "184dc70fab7d46d09b9148ca4448f07f1e0a2df2";
+    sha256 = "1dsqsfacvd9xqsqjzh6xwbnf2mv1dvhy210riyvjd260q085ch6n";
   };
 
-  patches = [ disable-tests ];
-
   buildInputs = [ ocaml findlib ocamlbuild camlp4 ];
-  propagatedBuildInputs = [ erm_xml cryptokit ];
+  propagatedBuildInputs = [ erm_xml nocrypto ];
+
+  configurePhase = "ocaml setup.ml -configure --prefix $out";
+  buildPhase = "ocaml setup.ml -build";
+  installPhase = "ocaml setup.ml -install";
 
   createFindlibDestdir = true;
 
   meta = {
-    homepage = https://github.com/ermine/xmpp;
-    description = "OCaml based XMPP implementation";
-    platforms = ocaml.meta.platforms or [];
+    homepage = https://github.com/hannesm/xmpp;
+    description = "OCaml based XMPP implementation (fork)";
     license = stdenv.lib.licenses.bsd3;
-    maintainers = with stdenv.lib.maintainers; [ vbgl ];
+    maintainers = with stdenv.lib.maintainers; [ sternenseemann ];
+    inherit (ocaml.meta) platforms;
   };
 }