summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2017-08-23 14:18:44 +0200
committerPeter Simons <simons@cryp.to>2017-08-23 19:53:10 +0200
commit1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1 (patch)
tree1cbfdaa4cbcfa2592489dec61f399b789a2f5410 /pkgs/development
parent92bc6a7bbc30af2a722d8f207275dd07c59c5bfb (diff)
downloadnixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.tar
nixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.tar.gz
nixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.tar.bz2
nixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.tar.lz
nixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.tar.xz
nixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.tar.zst
nixlib-1e4c4ccb5d58e22072d0c9bc0973a6c1212b23b1.zip
haskell-distributive: fix build on GHC versions older than 8.x
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-7.10.x.nix2
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix2
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-7.8.x.nix2
3 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-7.10.x.nix b/pkgs/development/haskell-modules/configuration-ghc-7.10.x.nix
index 74e1c21c581f..4e5eabae8020 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-7.10.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-7.10.x.nix
@@ -183,7 +183,7 @@ self: super: {
 
   # GHC versions prior to 8.x require additional build inputs.
   dependent-map = addBuildDepend super.dependent-map self.semigroups;
-  distributive = addBuildDepend super.distributive self.semigroups;
+  distributive = addBuildDepend (dontCheck super.distributive) self.semigroups;
   mono-traversable = addBuildDepend super.mono-traversable self.semigroups;
   attoparsec = addBuildDepends super.attoparsec (with self; [semigroups fail]);
   Glob = addBuildDepends super.Glob (with self; [semigroups]);
diff --git a/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix b/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix
index a096dc9ce8cd..ccb71773f2bf 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-7.6.x.nix
@@ -96,7 +96,7 @@ self: super: {
   # Needs additional inputs on old compilers.
   semigroups = addBuildDepends super.semigroups (with self; [bytestring-builder nats tagged unordered-containers transformers]);
   lens = addBuildDepends super.lens (with self; [doctest generic-deriving nats simple-reflect]);
-  distributive = addBuildDepend super.distributive self.semigroups;
+  distributive = addBuildDepend (dontCheck super.distributive) self.semigroups;
   QuickCheck = addBuildDepend super.QuickCheck self.semigroups;
   void = addBuildDepends super.void (with self; [hashable semigroups]);
   optparse-applicative = addBuildDepend super.optparse-applicative self.semigroups;
diff --git a/pkgs/development/haskell-modules/configuration-ghc-7.8.x.nix b/pkgs/development/haskell-modules/configuration-ghc-7.8.x.nix
index f82bcb4e646c..31e56db92231 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-7.8.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-7.8.x.nix
@@ -146,7 +146,7 @@ self: super: {
   # Needs additional inputs on old compilers.
   semigroups = addBuildDepends super.semigroups (with self; [nats tagged unordered-containers]);
   lens = addBuildDepends super.lens (with self; [doctest generic-deriving nats simple-reflect]);
-  distributive = addBuildDepend super.distributive self.semigroups;
+  distributive = addBuildDepend (dontCheck super.distributive) self.semigroups;
   QuickCheck = addBuildDepends super.QuickCheck (with self; [nats semigroups]);
   void = addBuildDepends super.void (with self; [hashable semigroups]);
   optparse-applicative = addBuildDepend super.optparse-applicative self.semigroups;