summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorYacine Hmito <yacine.hmito@gmail.com>2016-01-18 00:42:54 +0100
committerYacine Hmito <yacine.hmito@gmail.com>2016-01-18 00:42:54 +0100
commit1d8313042da7906f9166ef839ce024062fce3e83 (patch)
treec8ec5b43855e343ca9e4bcede052d54b04eb8947 /pkgs/development
parent0f107fcb67c50c1d8c908a69fa442604f48b82ba (diff)
downloadnixlib-1d8313042da7906f9166ef839ce024062fce3e83.tar
nixlib-1d8313042da7906f9166ef839ce024062fce3e83.tar.gz
nixlib-1d8313042da7906f9166ef839ce024062fce3e83.tar.bz2
nixlib-1d8313042da7906f9166ef839ce024062fce3e83.tar.lz
nixlib-1d8313042da7906f9166ef839ce024062fce3e83.tar.xz
nixlib-1d8313042da7906f9166ef839ce024062fce3e83.tar.zst
nixlib-1d8313042da7906f9166ef839ce024062fce3e83.zip
Renamed subdirectories in Android SKD's build-tools
Nix unzips the different components of the Android SDK one by one.
It followed the directory structure of complete packages released for
mainstream OS but the names of the directories in build-tools doesn't
match those.
As a result, some programs assuming the usual directory structure and
naming conventions broke (in my case it is a gradle plugin).
This is a fix. It may introduce a regression if some programs rely on
the current behavior.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/mobile/androidenv/androidsdk.nix2
-rw-r--r--pkgs/development/mobile/androidenv/build-tools.nix3
2 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/development/mobile/androidenv/androidsdk.nix b/pkgs/development/mobile/androidenv/androidsdk.nix
index 02c1546ace7b..01ba759f4f69 100644
--- a/pkgs/development/mobile/androidenv/androidsdk.nix
+++ b/pkgs/development/mobile/androidenv/androidsdk.nix
@@ -219,7 +219,7 @@ stdenv.mkDerivation rec {
         fi
     done
 
-    for i in $out/libexec/android-sdk-*/build-tools/android-*/*
+    for i in $out/libexec/android-sdk-*/build-tools/*/*
     do
         if [ ! -d $i ] && [ -x $i ]
         then
diff --git a/pkgs/development/mobile/androidenv/build-tools.nix b/pkgs/development/mobile/androidenv/build-tools.nix
index 1b49c8f6fc4e..2918acd8c15e 100644
--- a/pkgs/development/mobile/androidenv/build-tools.nix
+++ b/pkgs/development/mobile/androidenv/build-tools.nix
@@ -18,10 +18,11 @@ stdenv.mkDerivation rec {
     mkdir -p $out/build-tools
     cd $out/build-tools
     unzip $src
+    mv android-* ${version}
     
     ${stdenv.lib.optionalString (stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux")
       ''
-        cd android-*
+        cd ${version}
         
         # Patch the interpreter
         for i in aapt aidl bcc_compat dexdump llvm-rs-cc