summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-10-08 16:34:46 +0000
committerVincent Laporte <vbgl@users.noreply.github.com>2018-10-10 17:15:45 +0000
commit1c7c1be1a8a3324dfdc4f01945661a0246d92331 (patch)
tree4ed6e65484be0df925e1622aac40dc90a140e816 /pkgs/development
parentfc29f68e3f2af611f3d253b8fa9fc59ba227bebb (diff)
downloadnixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.tar
nixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.tar.gz
nixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.tar.bz2
nixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.tar.lz
nixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.tar.xz
nixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.tar.zst
nixlib-1c7c1be1a8a3324dfdc4f01945661a0246d92331.zip
ocamlPackages.merlin: 3.1.0 -> 3.2.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/ocaml/merlin/default.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/pkgs/development/tools/ocaml/merlin/default.nix b/pkgs/development/tools/ocaml/merlin/default.nix
index 4ad1bfb3234d..d74b480c9c5a 100644
--- a/pkgs/development/tools/ocaml/merlin/default.nix
+++ b/pkgs/development/tools/ocaml/merlin/default.nix
@@ -1,10 +1,9 @@
-{ stdenv, fetchzip, ocaml, findlib, yojson
-, withEmacsMode ? false, emacs }:
+{ stdenv, fetchzip, ocaml, findlib, dune, yojson }:
 
 assert stdenv.lib.versionAtLeast ocaml.version "4.02";
 
 let
-  version = "3.1.0";
+  version = "3.2.1";
 in
 
 stdenv.mkDerivation {
@@ -13,15 +12,12 @@ stdenv.mkDerivation {
 
   src = fetchzip {
     url = "https://github.com/ocaml/merlin/archive/v${version}.tar.gz";
-    sha256 = "1vf0c2mmflp94r8hshb44lsvnfdy03ld6mld2n79cdxr3zl24ci2";
+    sha256 = "1szv2b7d12ll5n6pvnhlv3a6vnlyrkpya4l9fiyyiwyvgd4xzxwf";
   };
 
-  buildInputs = [ ocaml findlib yojson ]
-    ++ stdenv.lib.optional withEmacsMode emacs;
+  buildInputs = [ ocaml findlib dune yojson ];
 
-  preConfigure = "mkdir -p $out/bin";
-  prefixKey = "--prefix ";
-  configureFlags = stdenv.lib.optional withEmacsMode "--enable-compiled-emacs-mode";
+  inherit (dune) installPhase;
 
   meta = with stdenv.lib; {
     description = "An editor-independent tool to ease the development of programs in OCaml";