summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2017-09-03 20:54:32 +0300
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2017-09-04 11:09:32 +0200
commit145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a (patch)
tree1925e329c8bee9c918c6138bdd3eca81c48ddfb9 /pkgs/development
parent81d2549e8b49fdf3f6e826dc96ad602d822b2714 (diff)
downloadnixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.gz
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.bz2
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.lz
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.xz
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.zst
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.zip
pythonPackages.attrs: 16.2.0 -> 17.2.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/attrs/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/attrs/default.nix b/pkgs/development/python-modules/attrs/default.nix
new file mode 100644
index 000000000000..e58bf3846dc9
--- /dev/null
+++ b/pkgs/development/python-modules/attrs/default.nix
@@ -0,0 +1,28 @@
+{ lib, stdenv, buildPythonPackage, fetchPypi, pytest, hypothesis, zope_interface
+, pympler, coverage, six, clang }:
+
+buildPythonPackage rec {
+  name = "${pname}-${version}";
+  pname = "attrs";
+  version = "17.2.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "04gx08ikpk26wnq22f7l42gapcvk8iz1512r927k6sadz6cinkax";
+  };
+
+  # macOS needs clang for testing
+  buildInputs = [
+    pytest hypothesis zope_interface pympler coverage six
+  ] ++ lib.optionals (stdenv.isDarwin) [ clang ];
+
+  checkPhase = ''
+    py.test
+  '';
+
+  meta = with lib; {
+    description = "Python attributes without boilerplate";
+    homepage = https://github.com/hynek/attrs;
+    license = licenses.mit;
+  };
+}