summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@users.noreply.github.com>2016-04-19 16:14:19 +0200
committerJoachim Fasting <joachifm@users.noreply.github.com>2016-04-19 16:14:19 +0200
commit1451bb8a18ffc935a8a13392ff6ef07b9676e711 (patch)
tree3261295b07f87ef9b69319fdd8a41e526840cece /pkgs/development
parent7660819b48c94a27a4545753c6c5c4626773b5a2 (diff)
parent0ebe9010357317f2261ebdbbd97b62f7a4ff070e (diff)
downloadnixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.tar
nixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.tar.gz
nixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.tar.bz2
nixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.tar.lz
nixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.tar.xz
nixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.tar.zst
nixlib-1451bb8a18ffc935a8a13392ff6ef07b9676e711.zip
Merge pull request #14811 from rasendubi/avro-cpp
avro-c++: Init at 1.7.5
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/avro-c++/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/development/libraries/avro-c++/default.nix b/pkgs/development/libraries/avro-c++/default.nix
new file mode 100644
index 000000000000..2cd03253e7e4
--- /dev/null
+++ b/pkgs/development/libraries/avro-c++/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, cmake, boost155, pythonPackages
+}:
+
+let version = "1.7.5"; in
+
+stdenv.mkDerivation {
+  name = "avro-c++-${version}";
+
+  src = fetchurl {
+    url = "mirror://apache/avro/avro-${version}/cpp/avro-cpp-${version}.tar.gz";
+    sha256 = "064ssbbgrc3hyalzj8rn119bsrnyk1vlpkhl8gghv96jgqbpdyb3";
+  };
+
+  buildInputs = [
+    cmake
+    boost155
+    pythonPackages.python
+  ];
+
+  enableParallelBuilding = true;
+
+  meta = {
+    description = "A C++ library which implements parts of the Avro Specification";
+    homepage = https://avro.apache.org/;
+    license = stdenv.lib.licenses.asl20;
+    maintainers = with stdenv.lib.maintainers; [ rasendubi ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}