summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSébastien Maret <sebastien.maret@univ-grenoble-alpes.fr>2018-05-28 12:50:10 +0200
committerSébastien Maret <sebastien.maret@univ-grenoble-alpes.fr>2018-05-28 13:30:51 +0200
commit12a46601e9ca199d41b039cf585a4b779820baff (patch)
treef7c6e61332ccfaf92cb3d5edb357896c166e3327 /pkgs/development
parent3b9a34ff30767613a589e3afb128f94f106f2d59 (diff)
downloadnixlib-12a46601e9ca199d41b039cf585a4b779820baff.tar
nixlib-12a46601e9ca199d41b039cf585a4b779820baff.tar.gz
nixlib-12a46601e9ca199d41b039cf585a4b779820baff.tar.bz2
nixlib-12a46601e9ca199d41b039cf585a4b779820baff.tar.lz
nixlib-12a46601e9ca199d41b039cf585a4b779820baff.tar.xz
nixlib-12a46601e9ca199d41b039cf585a4b779820baff.tar.zst
nixlib-12a46601e9ca199d41b039cf585a4b779820baff.zip
spectral-cube: init at 0.4.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/spectral-cube/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/spectral-cube/default.nix b/pkgs/development/python-modules/spectral-cube/default.nix
new file mode 100644
index 000000000000..3f54fefadf24
--- /dev/null
+++ b/pkgs/development/python-modules/spectral-cube/default.nix
@@ -0,0 +1,30 @@
+{ lib
+, fetchPypi
+, buildPythonPackage
+, astropy
+, radio_beam
+, pytest }:
+
+buildPythonPackage rec {
+  pname = "spectral-cube";
+  version = "0.4.3";
+
+  doCheck = false; # the tests requires several pytest plugins that are not in nixpkgs
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "057g3mzlg5cy4wg2hh3p6gssn93rs6i7pswzhldvcq4k8m8hsl3b";
+  };
+
+  propagatedBuildInputs = [ astropy radio_beam pytest ];
+
+  meta = {
+    description = "Library for reading and analyzing astrophysical spectral data cubes";
+    homepage = http://radio-astro-tools.github.io;
+    license = lib.licenses.bsd3;
+    platforms = lib.platforms.all;
+    maintainers = with lib.maintainers; [ smaret ];
+  };
+}
+
+