summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2016-08-11 22:31:04 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2016-08-16 19:25:42 +0000
commit122bac8f26bf265c57c877c56bf43137d32bf824 (patch)
tree5103088fc0c2983a4e41d55befe2eedffd53420f /pkgs/development
parentae75531b3ccb6faee0016bfef40aaf7cc6003ecc (diff)
downloadnixlib-122bac8f26bf265c57c877c56bf43137d32bf824.tar
nixlib-122bac8f26bf265c57c877c56bf43137d32bf824.tar.gz
nixlib-122bac8f26bf265c57c877c56bf43137d32bf824.tar.bz2
nixlib-122bac8f26bf265c57c877c56bf43137d32bf824.tar.lz
nixlib-122bac8f26bf265c57c877c56bf43137d32bf824.tar.xz
nixlib-122bac8f26bf265c57c877c56bf43137d32bf824.tar.zst
nixlib-122bac8f26bf265c57c877c56bf43137d32bf824.zip
libfreefare: fix darwin build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libfreefare/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/development/libraries/libfreefare/default.nix b/pkgs/development/libraries/libfreefare/default.nix
index 8c485fef47c9..291f20a5db2c 100644
--- a/pkgs/development/libraries/libfreefare/default.nix
+++ b/pkgs/development/libraries/libfreefare/default.nix
@@ -1,4 +1,5 @@
-{ stdenv, fetchurl, pkgconfig, libnfc, openssl }:
+{ stdenv, fetchurl, pkgconfig, libnfc, openssl
+, libobjc ? null }:
 
 stdenv.mkDerivation rec {
   name = "libfreefare-${version}";
@@ -9,7 +10,7 @@ stdenv.mkDerivation rec {
     sha256 = "0r5wfvwgf35lb1v65wavnwz2wlfyfdims6a9xpslf4lsm4a1v8xz";
   };
 
-  buildInputs = [ pkgconfig libnfc openssl ];
+  buildInputs = [ pkgconfig libnfc openssl ] ++ stdenv.lib.optional stdenv.isDarwin libobjc;
 
   meta = with stdenv.lib; {
     description = "The libfreefare project aims to provide a convenient API for MIFARE card manipulations";