summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2013-09-06 15:51:38 +0200
committerVladimír Čunát <vcunat@gmail.com>2013-09-06 15:51:38 +0200
commit0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89 (patch)
treee1943c894c4eb256ecf045d033366fb79ba312cc /pkgs/development
parente12c5deabe155a707c2fe7cea734f62868f40897 (diff)
downloadnixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.tar
nixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.tar.gz
nixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.tar.bz2
nixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.tar.lz
nixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.tar.xz
nixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.tar.zst
nixlib-0cf8a74e82f25cc6f5b94f50358f1bfbfb379e89.zip
dbus: minor update, style refactoring, parallel build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/dbus/default.nix56
1 files changed, 31 insertions, 25 deletions
diff --git a/pkgs/development/libraries/dbus/default.nix b/pkgs/development/libraries/dbus/default.nix
index d50a0076e62a..fe4be4f37263 100644
--- a/pkgs/development/libraries/dbus/default.nix
+++ b/pkgs/development/libraries/dbus/default.nix
@@ -3,8 +3,8 @@
 , libX11, libICE, libSM, useX11 ? stdenv.isLinux }:
 
 let
-  version = "1.6.12"; # 1.7.* isn't recommended, even for gnome 3.8
-  sha256 = "14pfh2ksn4srfry752kf1jy3c61hklcs9fx2xglw2ifhsszplypn";
+  version = "1.6.14"; # 1.7.* isn't recommended, even for gnome 3.8
+  sha256 = "0v7mcxwfmpjf7vndnvf2kf02al61clrxs36bqii20s0lawfh2xjn";
 
   inherit (stdenv) lib;
 
@@ -25,12 +25,26 @@ let
       inherit sha256;
     };
 
-    configureFlags = [
-      "--localstatedir=/var"
-      "--sysconfdir=/etc"
-      "--with-session-socket-dir=/tmp"
-      "--with-systemdsystemunitdir=$(out)/lib/systemd"
-    ];
+    patches = [
+        ./ignore-missing-includedirs.patch
+        ./ucred-dirty-hack.patch
+        ./no-create-dirs.patch
+      ]
+      ++ lib.optional (stdenv.isSunOS || stdenv.isLinux) ./implement-getgrouplist.patch
+      ;
+
+    # build only the specified subdirs
+    postPatch = "sed '/SUBDIRS/s/=.*/=" + subdirs + "/' -i Makefile.am\n"
+      # use already packaged libdbus instead of trying to build it again
+      + lib.optionalString (name != "libs") ''
+          for mfile in */Makefile.am; do
+            sed 's,\$(top_builddir)/dbus/\(libdbus-[0-9]\),${libs}/lib/\1,g' -i "$mfile"
+          done
+        '';
+
+    nativeBuildInputs = [ pkgconfig ];
+    propagatedBuildInputs = [ expat ];
+    buildInputs = [ autoconf automake libtool ]; # ToDo: optional selinux?
 
     preConfigure = ''
       patchShebangs .
@@ -38,26 +52,18 @@ let
       autoreconf -fi
     '';
 
-    installFlags = "sysconfdir=$(out)/etc";
-
-    doCheck = true;
+    configureFlags = [
+      "--localstatedir=/var"
+      "--sysconfdir=/etc"
+      "--with-session-socket-dir=/tmp"
+      "--with-systemdsystemunitdir=$(out)/lib/systemd"
+    ];
 
-    patches = [ ./ignore-missing-includedirs.patch ]
-      ++ lib.optional (stdenv.isSunOS || stdenv.isLinux/*avoid rebuilds*/) ./implement-getgrouplist.patch
-      ++ [ ./ucred-dirty-hack.patch ./no-create-dirs.patch ];
+    enableParallelBuilding = true;
 
-    nativeBuildInputs = [ pkgconfig ];
-    propagatedBuildInputs = [ expat ];
-    buildInputs = [ autoconf automake libtool ]; # ToDo: optional selinux?
+    doCheck = true;
 
-    # build only the specified subdirs
-    postPatch = "sed '/SUBDIRS/s/=.*/=" + subdirs + "/' -i Makefile.am\n"
-      # use already packaged libdbus instead of trying to build it again
-      + lib.optionalString (name != "libs") ''
-          for mfile in */Makefile.am; do
-            sed 's,\$(top_builddir)/dbus/\(libdbus-[0-9]\),${libs}/lib/\1,g' -i "$mfile"
-          done
-        '';
+    installFlags = "sysconfdir=$(out)/etc";
 
   } merge ]);