summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFlorian Friesdorf <flo@chaoflow.net>2013-03-02 16:00:50 +0100
committerFlorian Friesdorf <flo@chaoflow.net>2013-03-02 16:01:42 +0100
commit06e4059f80e95061c4f53200bf5892d4543b5d14 (patch)
treea0a3c684596efd8dccf7e14e248847278e2270a8 /pkgs/development
parentb6452df939e3e67546f6fe7af359d42d975d6769 (diff)
downloadnixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.tar
nixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.tar.gz
nixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.tar.bz2
nixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.tar.lz
nixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.tar.xz
nixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.tar.zst
nixlib-06e4059f80e95061c4f53200bf5892d4543b5d14.zip
fix pythonDocs install path
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/python/docs/2.6-html.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.6-pdf-a4.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.6-pdf-letter.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.6-text.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.7-html.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.7-pdf-a4.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.7-pdf-letter.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/2.7-text.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.0-html.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.0-pdf-a4.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.0-pdf-letter.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.0-text.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.1-html.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.1-pdf-a4.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.1-pdf-letter.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.1-text.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.2-html.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.2-pdf-a4.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.2-pdf-letter.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.2-text.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.3-html.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.3-pdf-a4.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.3-pdf-letter.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/3.3-text.nix4
-rw-r--r--pkgs/development/interpreters/python/docs/template.nix4
25 files changed, 50 insertions, 50 deletions
diff --git a/pkgs/development/interpreters/python/docs/2.6-html.nix b/pkgs/development/interpreters/python/docs/2.6-html.nix
index 481998ae5916..66f8c9ae996b 100644
--- a/pkgs/development/interpreters/python/docs/2.6-html.nix
+++ b/pkgs/development/interpreters/python/docs/2.6-html.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python26-docs-html-2.6.8";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.6.8/python-2.6.8-docs-html.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.6-pdf-a4.nix b/pkgs/development/interpreters/python/docs/2.6-pdf-a4.nix
index 1a718819ac0e..c3da7e1dc119 100644
--- a/pkgs/development/interpreters/python/docs/2.6-pdf-a4.nix
+++ b/pkgs/development/interpreters/python/docs/2.6-pdf-a4.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python26-docs-pdf-a4-2.6.8";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.6.8/python-2.6.8-docs-pdf-a4.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.6-pdf-letter.nix b/pkgs/development/interpreters/python/docs/2.6-pdf-letter.nix
index 305c456efc45..b17be3da822e 100644
--- a/pkgs/development/interpreters/python/docs/2.6-pdf-letter.nix
+++ b/pkgs/development/interpreters/python/docs/2.6-pdf-letter.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python26-docs-pdf-letter-2.6.8";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.6.8/python-2.6.8-docs-pdf-letter.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.6-text.nix b/pkgs/development/interpreters/python/docs/2.6-text.nix
index 6ced3597eeb8..64b44adcccd5 100644
--- a/pkgs/development/interpreters/python/docs/2.6-text.nix
+++ b/pkgs/development/interpreters/python/docs/2.6-text.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python26-docs-text-2.6.8";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.6.8/python-2.6.8-docs-text.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.7-html.nix b/pkgs/development/interpreters/python/docs/2.7-html.nix
index 1c8ef0bc4603..7db8d04403c3 100644
--- a/pkgs/development/interpreters/python/docs/2.7-html.nix
+++ b/pkgs/development/interpreters/python/docs/2.7-html.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python27-docs-html-2.7.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.7.3/python-2.7.3-docs-html.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.7-pdf-a4.nix b/pkgs/development/interpreters/python/docs/2.7-pdf-a4.nix
index d2d9f3616cee..fcabd3f4b56f 100644
--- a/pkgs/development/interpreters/python/docs/2.7-pdf-a4.nix
+++ b/pkgs/development/interpreters/python/docs/2.7-pdf-a4.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python27-docs-pdf-a4-2.7.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.7.3/python-2.7.3-docs-pdf-a4.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.7-pdf-letter.nix b/pkgs/development/interpreters/python/docs/2.7-pdf-letter.nix
index 0361d3a20278..643a2ba2a88d 100644
--- a/pkgs/development/interpreters/python/docs/2.7-pdf-letter.nix
+++ b/pkgs/development/interpreters/python/docs/2.7-pdf-letter.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python27-docs-pdf-letter-2.7.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.7.3/python-2.7.3-docs-pdf-letter.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/2.7-text.nix b/pkgs/development/interpreters/python/docs/2.7-text.nix
index 4422822cced9..65b236f4e890 100644
--- a/pkgs/development/interpreters/python/docs/2.7-text.nix
+++ b/pkgs/development/interpreters/python/docs/2.7-text.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python27-docs-text-2.7.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/2.7.3/python-2.7.3-docs-text.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.0-html.nix b/pkgs/development/interpreters/python/docs/3.0-html.nix
index 6abc92b18539..9c20d6cad4cd 100644
--- a/pkgs/development/interpreters/python/docs/3.0-html.nix
+++ b/pkgs/development/interpreters/python/docs/3.0-html.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python30-docs-html-3.0.1";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.0.1/python-3.0.1-docs-html.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.0-pdf-a4.nix b/pkgs/development/interpreters/python/docs/3.0-pdf-a4.nix
index 658cfd27ee7b..5a8fcb1ce402 100644
--- a/pkgs/development/interpreters/python/docs/3.0-pdf-a4.nix
+++ b/pkgs/development/interpreters/python/docs/3.0-pdf-a4.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python30-docs-pdf-a4-3.0.1";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.0.1/python-3.0.1-docs-pdf-a4.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.0-pdf-letter.nix b/pkgs/development/interpreters/python/docs/3.0-pdf-letter.nix
index 5a86ea0a7017..cf5116dac48b 100644
--- a/pkgs/development/interpreters/python/docs/3.0-pdf-letter.nix
+++ b/pkgs/development/interpreters/python/docs/3.0-pdf-letter.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python30-docs-pdf-letter-3.0.1";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.0.1/python-3.0.1-docs-pdf-letter.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.0-text.nix b/pkgs/development/interpreters/python/docs/3.0-text.nix
index 4031594e768d..c1af5cd686b9 100644
--- a/pkgs/development/interpreters/python/docs/3.0-text.nix
+++ b/pkgs/development/interpreters/python/docs/3.0-text.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python30-docs-text-3.0.1";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.0.1/python-3.0.1-docs-text.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.1-html.nix b/pkgs/development/interpreters/python/docs/3.1-html.nix
index 7226cbde3bdf..d85007ee455e 100644
--- a/pkgs/development/interpreters/python/docs/3.1-html.nix
+++ b/pkgs/development/interpreters/python/docs/3.1-html.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python31-docs-html-3.1.5";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.1.5/python-3.1.5-docs-html.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.1-pdf-a4.nix b/pkgs/development/interpreters/python/docs/3.1-pdf-a4.nix
index ddde9ccfe2e9..0a260e86e7d7 100644
--- a/pkgs/development/interpreters/python/docs/3.1-pdf-a4.nix
+++ b/pkgs/development/interpreters/python/docs/3.1-pdf-a4.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python31-docs-pdf-a4-3.1.5";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.1.5/python-3.1.5-docs-pdf-a4.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.1-pdf-letter.nix b/pkgs/development/interpreters/python/docs/3.1-pdf-letter.nix
index 929ecbdb92c3..e54ec24490a0 100644
--- a/pkgs/development/interpreters/python/docs/3.1-pdf-letter.nix
+++ b/pkgs/development/interpreters/python/docs/3.1-pdf-letter.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python31-docs-pdf-letter-3.1.5";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.1.5/python-3.1.5-docs-pdf-letter.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.1-text.nix b/pkgs/development/interpreters/python/docs/3.1-text.nix
index 76caa5e52325..ea6376744698 100644
--- a/pkgs/development/interpreters/python/docs/3.1-text.nix
+++ b/pkgs/development/interpreters/python/docs/3.1-text.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python31-docs-text-3.1.5";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.1.5/python-3.1.5-docs-text.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.2-html.nix b/pkgs/development/interpreters/python/docs/3.2-html.nix
index 3df6e1da0f9c..c55ad82a985f 100644
--- a/pkgs/development/interpreters/python/docs/3.2-html.nix
+++ b/pkgs/development/interpreters/python/docs/3.2-html.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python32-docs-html-3.2.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.2.3/python-3.2.3-docs-html.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.2-pdf-a4.nix b/pkgs/development/interpreters/python/docs/3.2-pdf-a4.nix
index 6d37cc86d95c..3c19afa16b74 100644
--- a/pkgs/development/interpreters/python/docs/3.2-pdf-a4.nix
+++ b/pkgs/development/interpreters/python/docs/3.2-pdf-a4.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python32-docs-pdf-a4-3.2.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.2.3/python-3.2.3-docs-pdf-a4.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.2-pdf-letter.nix b/pkgs/development/interpreters/python/docs/3.2-pdf-letter.nix
index 578e69697489..5b3180c415c6 100644
--- a/pkgs/development/interpreters/python/docs/3.2-pdf-letter.nix
+++ b/pkgs/development/interpreters/python/docs/3.2-pdf-letter.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python32-docs-pdf-letter-3.2.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.2.3/python-3.2.3-docs-pdf-letter.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.2-text.nix b/pkgs/development/interpreters/python/docs/3.2-text.nix
index 062732e9cea5..8cf4160a76a9 100644
--- a/pkgs/development/interpreters/python/docs/3.2-text.nix
+++ b/pkgs/development/interpreters/python/docs/3.2-text.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python32-docs-text-3.2.3";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.2.3/python-3.2.3-docs-text.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.3-html.nix b/pkgs/development/interpreters/python/docs/3.3-html.nix
index 6530153c51b8..5421e6be195b 100644
--- a/pkgs/development/interpreters/python/docs/3.3-html.nix
+++ b/pkgs/development/interpreters/python/docs/3.3-html.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python33-docs-html-3.3.0";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.3.0/python-3.3.0-docs-html.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.3-pdf-a4.nix b/pkgs/development/interpreters/python/docs/3.3-pdf-a4.nix
index 037e53e63d67..7326a1b3c927 100644
--- a/pkgs/development/interpreters/python/docs/3.3-pdf-a4.nix
+++ b/pkgs/development/interpreters/python/docs/3.3-pdf-a4.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python33-docs-pdf-a4-3.3.0";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.3.0/python-3.3.0-docs-pdf-a4.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.3-pdf-letter.nix b/pkgs/development/interpreters/python/docs/3.3-pdf-letter.nix
index e4dd3dc7ebc6..c918ecc6f4f8 100644
--- a/pkgs/development/interpreters/python/docs/3.3-pdf-letter.nix
+++ b/pkgs/development/interpreters/python/docs/3.3-pdf-letter.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python33-docs-pdf-letter-3.3.0";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.3.0/python-3.3.0-docs-pdf-letter.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/3.3-text.nix b/pkgs/development/interpreters/python/docs/3.3-text.nix
index f3a0c049dd13..99752b9d08d4 100644
--- a/pkgs/development/interpreters/python/docs/3.3-text.nix
+++ b/pkgs/development/interpreters/python/docs/3.3-text.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "python33-docs-text-3.3.0";
   src = fetchurl {
     url = http://docs.python.org/ftp/python/doc/3.3.0/python-3.3.0-docs-text.tar.bz2;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }
diff --git a/pkgs/development/interpreters/python/docs/template.nix b/pkgs/development/interpreters/python/docs/template.nix
index 621bf9e7cd92..263878b3f758 100644
--- a/pkgs/development/interpreters/python/docs/template.nix
+++ b/pkgs/development/interpreters/python/docs/template.nix
@@ -2,7 +2,7 @@
 
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "pythonMAJORMINOR-docs-TYPE-VERSION";
   src = fetchurl {
     url = URL;
@@ -10,6 +10,6 @@ stdenv.mkDerivation {
   };
   installPhase = ''
     mkdir -p $out/share/docs
-    cp -R ./ $out/share/docs/
+    cp -R ./ $out/share/docs/${name}
   '';
 }