summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLéo Gaspard <leo@gaspard.io>2018-08-13 14:47:54 +0900
committerLéo Gaspard <leo@gaspard.io>2018-09-23 22:33:09 +0900
commit0602e6ddfe361c82f7c8f1ed017a7af4c35a582d (patch)
treea422fec83bff6faa32e58960ede6c8aa84f9cbe8 /pkgs/development
parent7df10f388dabe9af3320fe91dd715fc84f4c7e8a (diff)
downloadnixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.tar
nixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.tar.gz
nixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.tar.bz2
nixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.tar.lz
nixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.tar.xz
nixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.tar.zst
nixlib-0602e6ddfe361c82f7c8f1ed017a7af4c35a582d.zip
wasm-gc: init at 0.1.6
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/wasm-gc/default.nix25
-rw-r--r--pkgs/development/interpreters/wasm-gc/fix-build.patch34
2 files changed, 59 insertions, 0 deletions
diff --git a/pkgs/development/interpreters/wasm-gc/default.nix b/pkgs/development/interpreters/wasm-gc/default.nix
new file mode 100644
index 000000000000..cf0fad18d1ca
--- /dev/null
+++ b/pkgs/development/interpreters/wasm-gc/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, rustPlatform }:
+
+rustPlatform.buildRustPackage rec {
+  name = "wasm-gc-${version}";
+  version = "0.1.6";
+
+  src = fetchFromGitHub {
+    owner = "alexcrichton";
+    repo = "wasm-gc";
+    rev = version;
+    sha256 = "1lc30xxqp3vv1r269xzznh2lf2dzdq89bi5f1vmqjw4yc3xmawm7";
+  };
+
+  cargoPatches = [ ./fix-build.patch ]; # Cargo.lock is not up-to-date
+
+  cargoSha256 = "1jvk9n324p3x3j6q6x0p5diig3b5c683k74cfflff25i7gsmmvc7";
+
+  meta = with stdenv.lib; {
+    description = "gc-sections for wasm";
+    homepage = "https://github.com/alexcrichton/wasm-gc";
+    maintainers = with maintainers; [ ekleog ];
+    platforms = platforms.all;
+    license = with licenses; [ mit asl20 ];
+  };
+}
diff --git a/pkgs/development/interpreters/wasm-gc/fix-build.patch b/pkgs/development/interpreters/wasm-gc/fix-build.patch
new file mode 100644
index 000000000000..3144dd898374
--- /dev/null
+++ b/pkgs/development/interpreters/wasm-gc/fix-build.patch
@@ -0,0 +1,34 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index 923ed91..71f17c8 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -212,16 +212,16 @@ dependencies = [
+ 
+ [[package]]
+ name = "wasm-gc"
+-version = "0.1.1"
++version = "0.1.6"
+ dependencies = [
+  "env_logger 0.5.10 (registry+https://github.com/rust-lang/crates.io-index)",
+  "getopts 0.2.17 (registry+https://github.com/rust-lang/crates.io-index)",
+- "wasm-gc-api 0.1.5",
++ "wasm-gc-api 0.1.6",
+ ]
+ 
+ [[package]]
+ name = "wasm-gc-api"
+-version = "0.1.5"
++version = "0.1.6"
+ dependencies = [
+  "log 0.4.1 (registry+https://github.com/rust-lang/crates.io-index)",
+  "parity-wasm 0.31.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -234,7 +234,7 @@ version = "0.1.0"
+ dependencies = [
+  "cfg-if 0.1.3 (registry+https://github.com/rust-lang/crates.io-index)",
+  "wasm-bindgen 0.2.11 (registry+https://github.com/rust-lang/crates.io-index)",
+- "wasm-gc-api 0.1.5",
++ "wasm-gc-api 0.1.6",
+ ]
+ 
+ [[package]]
+