summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-02-05 09:08:05 +0000
committerGitHub <noreply@github.com>2018-02-05 09:08:05 +0000
commit030badc427ff48d3b29ea43109b0612e489d4eff (patch)
tree7e5108936726fb347306e3223afbd0ced5015453 /pkgs/development
parentcdb8debfba7ee296f4d2bdb5d5da9aefb24fa2d7 (diff)
parent58e467c850435fd787dec70a6752d852fc6c67fa (diff)
downloadnixlib-030badc427ff48d3b29ea43109b0612e489d4eff.tar
nixlib-030badc427ff48d3b29ea43109b0612e489d4eff.tar.gz
nixlib-030badc427ff48d3b29ea43109b0612e489d4eff.tar.bz2
nixlib-030badc427ff48d3b29ea43109b0612e489d4eff.tar.lz
nixlib-030badc427ff48d3b29ea43109b0612e489d4eff.tar.xz
nixlib-030badc427ff48d3b29ea43109b0612e489d4eff.tar.zst
nixlib-030badc427ff48d3b29ea43109b0612e489d4eff.zip
Merge pull request #34596 from dotlambda/aioimaplib
python3Packages.aioimaplib: init at 0.7.13
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/aioimaplib/default.nix26
-rw-r--r--pkgs/development/python-modules/asynctest/default.nix33
-rw-r--r--pkgs/development/python-modules/imaplib2/default.nix22
3 files changed, 81 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/aioimaplib/default.nix b/pkgs/development/python-modules/aioimaplib/default.nix
new file mode 100644
index 000000000000..d335cbc556cb
--- /dev/null
+++ b/pkgs/development/python-modules/aioimaplib/default.nix
@@ -0,0 +1,26 @@
+{ lib, buildPythonPackage, fetchFromGitHub, pythonOlder
+, nose, asynctest, mock, pytz, tzlocal, imaplib2, docutils }:
+
+buildPythonPackage rec {
+  pname = "aioimaplib";
+  version = "0.7.13";
+
+  # PyPI tarball doesn't ship tests
+  src = fetchFromGitHub {
+    owner = "bamthomas";
+    repo = pname;
+    rev = version;
+    sha256 = "19yhk4ixfw46d0bvx6a40r23nvia5a83dzn5rzwaq1wdjr186bbn";
+  };
+
+  disbaled = pythonOlder "3.4";
+
+  checkInputs = [ nose asynctest mock pytz tzlocal imaplib2 docutils ];
+
+  meta = with lib; {
+    description = "Python asyncio IMAP4rev1 client library";
+    homepage = https://github.com/bamthomas/aioimaplib;
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}
diff --git a/pkgs/development/python-modules/asynctest/default.nix b/pkgs/development/python-modules/asynctest/default.nix
new file mode 100644
index 000000000000..2b0348a87581
--- /dev/null
+++ b/pkgs/development/python-modules/asynctest/default.nix
@@ -0,0 +1,33 @@
+{ lib, buildPythonPackage, fetchPypi, fetchFromGitHub, pythonOlder, python }:
+
+buildPythonPackage rec {
+  pname = "asynctest";
+  version = "0.11.1";
+
+  disabled = pythonOlder "3.4";
+
+  # PyPI tarball doesn't ship test/__init__.py
+  src = fetchFromGitHub {
+    owner = "Martiusweb";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1vvh5vbq2fbz6426figs85z8779r7svb4dp2v3xynhhv05nh2y6v";
+  };
+
+  postPatch = ''
+    # Skip failing test, probably caused by file system access
+    substituteInPlace test/test_selector.py \
+      --replace "test_events_watched_outside_test_are_ignored" "xtest_events_watched_outside_test_are_ignored"
+  '';
+
+  checkPhase = ''
+    ${python.interpreter} -m unittest test
+  '';
+
+  meta = with lib; {
+    description = "Enhance the standard unittest package with features for testing asyncio libraries";
+    homepage = https://github.com/Martiusweb/asynctest;
+    license = licenses.asl20;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}
diff --git a/pkgs/development/python-modules/imaplib2/default.nix b/pkgs/development/python-modules/imaplib2/default.nix
new file mode 100644
index 000000000000..0ceff353f9a6
--- /dev/null
+++ b/pkgs/development/python-modules/imaplib2/default.nix
@@ -0,0 +1,22 @@
+{ lib, buildPythonPackage, fetchPypi }:
+
+buildPythonPackage rec {
+  pname = "imaplib2";
+  version = "2.45.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "a35b6d88258696e80aabecfb784e08730b8558fcaaa3061ff2c7f8637afbd0b3";
+  };
+
+  # No tests on PyPI and no tags on GitHub :(
+  doCheck = false;
+
+  meta = with lib; {
+    description = "A threaded Python IMAP4 client";
+    homepage = https://github.com/bcoe/imaplib2;
+    # See https://github.com/bcoe/imaplib2/issues/25
+    license = licenses.psfl;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}